View Issue Details

IDProjectCategoryView StatusLast Update
0008140Kali Linux[All Projects] General Bugpublic2023-01-24 15:02
Reporternessus Assigned ToGamb1t  
PriorityimmediateSeveritymajorReproducibilityalways
Status acknowledgedResolutionopen 
Product Version2022.4 
Target VersionFixed in Version 
Summary0008140: Installation not working (Clean barbone install).
DescriptionWhen i try to install kali linux on a laptop, the installation freezes on "Detect Network Hardware".
I have tried every solution that i could find on Google, but it still wont run.
I tested to see if i could install Debian, and that works fine..

Activities

rhertzog

2023-01-16 15:21

administrator   ~0017399

I'm curious to know what Debian image you used. Can you share the link from where you downloaded it?

Can you try this Debian image and tell us if it works or not ?
http://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/weekly-builds/amd64/iso-cd/firmware-testing-amd64-netinst.iso

The default Debian image doesn't have firmware and this one is an image with firmware that is closer to what we are using in Kali.

rhertzog

2023-01-16 15:33

administrator   ~0017400

We would need more information about how the Kali installation fails. Once the installer is stuck, please type "CTRL+ALT+F4" to get to the fourth virtual terminal and take a screenshot of that terminal (and share it here).

You can also go to the second terminal with "CTRL+ALT+F2" and run some commands to interact with the installer environment. I would like to see the output of "ps" for example to know what processes are currently running (so that I can try to identify which one is getting stuck).

rhertzog

2023-01-16 15:37

administrator   ~0017401

Finally, it would help to know what hardware there is in your laptop, so it would be useful if you could share the output of "lspci", "lsusb" and "lshw" on a working installation. (Please run "lshw" as root to have the maximum number of details)

SnowPlay

2023-01-22 13:13

reporter   ~0017418

I have the same problem. When installing the installation froze when recognizing the hardware.
I also tried to install using the lagancy enable function. Disabling Secruboot also worked.

strg-alt-f4.jfif (286,018 bytes)
Spec.jfif (154,606 bytes)
Bios.jfif (101,320 bytes)

rhertzog

2023-01-23 16:05

administrator   ~0017419

A Debian bug report hints at a kernel issue with the mt7921e driver oopsing when the module is removed:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1029116

Possible mediatek hardware to reproduce the issue: https://www.aliexpress.us/item/1005003512734269.html?gatewayAdapt=4itemAdapt

SnowPlay

2023-01-23 16:09

reporter   ~0017420

That means if I remove the WLAN module, should the installation work? i will test it

steev

2023-01-23 16:16

manager   ~0017421

You don't need to remove the wifi module itself, you can attempt add modprobe.blacklist=mt7921e to the installer's `linux` line so that it doesn't attempt to load the module. Someone on the discord reported that they were able to complete the installation that way. Just make sure that that option is not still there after doing the installation. The issue is only due to the way hardware detection works.

SnowPlay

2023-01-23 16:34

reporter   ~0017422

how exactly do i do that? Unfortunately, I'm not such a professional that I do it like ganu or where I have to enter it. I tried to boot from the USB stick and then open the shell.

then I look for /etc/modprobe.d/blacklist.conf

but it doesn't exist or where do I have to enter it?

steev

2023-01-23 16:38

manager   ~0017423

on the screen where you choose which installation type to choose, Install/Graphical Install and so forth, instead of just hitting enter, you would hit "e" and then on the line that starts with "linux" you would move the cursor down to that line, then move to the very end of the line with the right arrow key (or hit ctrl+e) and then type in "modprobe.blacklist=mt7921e" without the quotes.

so the line should end up ending something along the lines of "--- quiet modprobe.blacklist=mt7921e"

SnowPlay

2023-01-23 16:52

reporter   ~0017424

the problem is still there

missing.jfif (310,351 bytes)
mod.jfif (165,095 bytes)

rhertzog

2023-01-24 13:28

administrator   ~0017425

SnowPlay, the screenshot is showing that you have some realtek card. Steev is giving you instructions for a known problem with a Mediatek card using the mt7921e driver, so it's to be expected that it doesn't help your case.

But your screenshot of the log screen shows zero error happening so it's not clear why and where it would be stuck. Can you try to share the output of the "ps" command that you would enter in the second terminal (CTRL+ALT+F2) while you are stuck? (As I requested in https://bugs.kali.org/view.php?id=8140#c17400)

SnowPlay

2023-01-24 15:02

reporter   ~0017426

Unfortunately, I can't give any exact details because the laptop freezes completely and it's not possible to switch to the other console.
After starting, I tried to jump directly into the console (CTRL+ALT+F2) and execute the "ps" command until the laptop frees itself.

ps.jfif (347,531 bytes)

Issue History

Date Modified Username Field Change
2023-01-11 07:13 nessus New Issue
2023-01-16 14:55 Gamb1t Assigned To => Gamb1t
2023-01-16 14:55 Gamb1t Status new => acknowledged
2023-01-16 15:21 rhertzog Note Added: 0017399
2023-01-16 15:33 rhertzog Note Added: 0017400
2023-01-16 15:37 rhertzog Note Added: 0017401
2023-01-22 13:13 SnowPlay File Added: strg-alt-f4.jfif
2023-01-22 13:13 SnowPlay File Added: Spec.jfif
2023-01-22 13:13 SnowPlay File Added: Bios.jfif
2023-01-22 13:13 SnowPlay Note Added: 0017418
2023-01-23 16:05 rhertzog Note Added: 0017419
2023-01-23 16:09 SnowPlay Note Added: 0017420
2023-01-23 16:16 steev Note Added: 0017421
2023-01-23 16:34 SnowPlay Note Added: 0017422
2023-01-23 16:38 steev Note Added: 0017423
2023-01-23 16:52 SnowPlay File Added: missing.jfif
2023-01-23 16:52 SnowPlay File Added: mod.jfif
2023-01-23 16:52 SnowPlay Note Added: 0017424
2023-01-24 13:28 rhertzog Note Added: 0017425
2023-01-24 15:02 SnowPlay File Added: ps.jfif
2023-01-24 15:02 SnowPlay Note Added: 0017426