View Issue Details

IDProjectCategoryView StatusLast Update
0008275Kali LinuxGeneral Bugpublic2023-08-31 19:23
ReporterSyrenRemix Assigned To 
PrioritylowSeverityblockReproducibilityalways
Status newResolutionopen 
Summary0008275: Underscore blinking
Description

When I load Kali Linux Amd64 using a Hyper-v VM once the logo pops up a underscore blinks continues & your basically stuck on it a boot loop

Steps To Reproduce

I've done everything I can to get off this screen I can't even log into Kali Linux, I can't get passed the Logo of Kali

Additional Information

I have tried changing the video adapter type: In Hyper-V Manager, right-click on your Kali Linux virtual machine, select "Settings", and then navigate to the "Display" section. Change the "Graphics adapter" to "Standard VGA" and then reboot the virtual machine.

Enable "Enhanced Session Mode": In Hyper-V Manager, right-click on your Kali Linux virtual machine, select "Settings", and then navigate to the "Enhanced Session Mode" section. Enable "Enhanced session mode" and check the box next to "Use enhanced session mode". This will allow you to use features such as clipboard sharing and file drag and drop between your host and virtual machine.

Use a different hypervisor: If you are unable to resolve the issue in Hyper-V, you could try using a different hypervisor such as VirtualBox or VMware.

Activities

arnaudr

arnaudr

2023-04-24 04:29

manager   ~0017822

Can you share a screenshot? There are different ways to connect to Hyper-V, a screenshot would help to understand better.

Even though, I don't have a setup to test Hyper-V images, I won't help much. You might have more luck if you report your issue on Kali's forums - https://forums.kali.org - or the Discord channel - https://discord.kali.org/ -

arnaudr

arnaudr

2023-04-24 05:11

manager   ~0017823

Also, is it a GEN1 or GEN2 hyper-v machine?

SyrenRemix

SyrenRemix

2023-04-24 14:02

reporter   ~0017824

These are what I tried to do to get in installed on my PC running W11 Pro maybe could be a problem with windows ��‍♂️.
I looked up help & was told to do this,

The blinking underscore issue in Kali Linux running on Hyper-V is usually caused by a misconfiguration of the boot loader. Here are some steps you can follow to fix the issue: Start your virtual machine and wait for it to boot up. Press the Esc key on your keyboard when the Kali Linux boot menu appears. Select "Advanced Options for Kali GNU/Linux" and press Enter. Select the first option that starts with "Kali GNU/Linux, with Linux" and press e to edit the boot parameters. Use the arrow keys to navigate to the end of the line that starts with "linux" and add "systemd.unit=multi-user.target" at the end of the line (without the quotes). Press Ctrl+X to boot the system with the new parameters. Once the system boots up, open a terminal and type the following command:

sudo update-grub

This will update the boot loader configuration with the new parameters. Reboot your system and the blinking underscore issue should be resolved.

I've done the above steps, but did not work, I even adjusted the settings in your Hyper-V virtual machine configuration. Specifically, to disable Secure Boot and/or enable Legacy boot support. I've tried right-clicking on the virtual machine in Hyper-V Manager, selecting "Settings", and then navigating to the "Security" and "Boot" tabs. Still doesn't work. You mentioned a Screenshot it's just a black screen with a underscore at the top left of your screen. Sorry I'm new so I couldn't figure out where to reply.

arnaudr

arnaudr

2023-04-25 05:04

manager   ~0017829

Is it a GEN1 or GEN2 Hyper-v machine? Check in the settings. If it's GEN1, please try again from zero: re-create a VM (GEN2 this time) and re-install Kali Linux.

SyrenRemix

SyrenRemix

2023-05-12 07:59

reporter   ~0017915

Yeah sorry for a long late response, I've had trouble with Internet, So I have tried GEN1 & GEN2 but both were unsuccessful I watched Network Chuck & got it to fix on a new user like a non administrator account, but I'd rather use the administrator account I have tried WSL 1 with the steps to install it in the Kali.org & it didn't work, this is the same error I have been experiencing https://youtu.be/hnTZMJJTy4g with the black screen underscore, hopefully you'd understand it better sorry for thes late response

steev

steev

2023-08-31 19:23

manager   ~0018426

Can you please try the 2023.3a release that we've recently posted for Hyper-V?

Issue History

Date Modified Username Field Change
2023-04-24 04:17 SyrenRemix New Issue
2023-04-24 04:29 arnaudr Note Added: 0017822
2023-04-24 05:11 arnaudr Note Added: 0017823
2023-04-24 14:02 SyrenRemix Note Added: 0017824
2023-04-25 05:04 arnaudr Note Added: 0017829
2023-05-12 07:59 SyrenRemix Note Added: 0017915
2023-08-31 19:23 steev Note Added: 0018426