View Issue Details

IDProjectCategoryView StatusLast Update
0008315Kali LinuxGeneral Bugpublic2023-05-19 01:15
Reporterarif_rahman_umam Assigned Toarnaudr  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0008315: No sound on Kali 2023.2

No sound after installing kali linux version 2023.2

I have done a full update and upgrade. but my laptop makes no sound. I am logged in as root user. using a laptop default sound card, laptop default speakers. using xfce desktop. I use dual boot, windows 11 and kali linux.

Additional Information

└─# dpkg -l | grep -E 'blue[tz]|pipewire|wireplumber|pulse'
ii blueman 2.3.5-2+b1 amd64 Graphical bluetooth manager
ii bluez 5.66-1+kali1 amd64 Bluetooth tools and daemons
ii bluez-firmware 1.2-9 all Firmware for Bluetooth devices
ii bluez-hcidump 5.66-1+kali1 amd64 Analyses Bluetooth HCI packets
ii bluez-obexd 5.66-1+kali1 amd64 bluez obex daemon
ii kismet-capture-linux-bluetooth 2022.08.R1-0kali3 amd64 Kismet Linux Bluetooth capture helper
ii libbluetooth3:amd64 5.66-1+kali1 amd64 Library to use the BlueZ Linux Bluetooth stack
ii libpipewire-0.3-0:amd64 0.3.65-3 amd64 libraries for the PipeWire multimedia server
ii libpipewire-0.3-common 0.3.65-3 all libraries for the PipeWire multimedia server - common files
ii libpipewire-0.3-modules:amd64 0.3.65-3 amd64 libraries for the PipeWire multimedia server - modules
ii libpulse-mainloop-glib0:amd64 16.1+dfsg1-2+b1 amd64 PulseAudio client libraries (glib support)
ii libpulse0:amd64 16.1+dfsg1-2+b1 amd64 PulseAudio client libraries
ii libpulsedsp:amd64 16.1+dfsg1-2+b1 amd64 PulseAudio OSS pre-load library
ii libspa-0.2-bluetooth:amd64 0.3.65-3 amd64 libraries for the PipeWire multimedia server - bluetooth plugins
ii libwireplumber-0.4-0:amd64 0.4.13-1 amd64 Shared libraries for WirePlumber
ii pipewire:amd64 0.3.65-3 amd64 audio and video processing engine multimedia server
ii pipewire-bin 0.3.65-3 amd64 PipeWire multimedia server - programs
ii pipewire-pulse 0.3.65-3 amd64 PipeWire PulseAudio daemon
ii pulseaudio 16.1+dfsg1-2+b1 amd64 PulseAudio sound server
ii pulseaudio-module-bluetooth 16.1+dfsg1-2+b1 amd64 Bluetooth module for PulseAudio sound server
ii pulseaudio-utils 16.1+dfsg1-2+b1 amd64 Command line tools for the PulseAudio sound server
ii wireplumber 0.4.13-1 amd64 modular session / policy manager for PipeWire
ii xfce4-pulseaudio-plugin:amd64 0.4.5-1 amd64 Xfce4 panel plugin to control pulseaudio

└─# ps -fp $(pgrep wire)
root 1104 1088 0 18:22 ? S<sl 0:14 /usr/bin/pipewire
root 1105 1088 0 18:22 ? S<sl 0:01 /usr/bin/wireplumber
root 1106 1088 1 18:22 ? S<Lsl 0:26 /usr/bin/pipewire-pulse

└─# systemctl --user status -n 100 pipewire-pulse
● pipewire-pulse.service - PipeWire PulseAudio
Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; enabled; preset: enabled)
Drop-In: /usr/lib/systemd/user/pipewire-pulse.service.d
Active: active (running) since Thu 2023-05-18 18:22:32 WIB; 34min ago
TriggeredBy: ● pipewire-pulse.socket
Main PID: 1106 (pipewire-pulse)
Tasks: 2 (limit: 9295)
Memory: 17.6M
CPU: 29.012s
CGroup: /user.slice/user-0.slice/[email protected]/session.slice/pipewire-pulse.service
└─1106 /usr/bin/pipewire-pulse

May 18 18:22:32 unknown systemd[1088]: Started pipewire-pulse.service - PipeWire PulseAudio.

└─# apt list '?installed !?automatic' | grep pipe

WARNING: apt does not have a stable CLI interface. Use with caution in scripts

Attached Files


duplicate of 0008299 resolvedarnaudr 0008250: No sound on kali 2023.1 




2023-05-18 14:35

manager   ~0017965

Can you try to login as non-root use then, to see if it works better? Also, I know it sounds dumb, but did you double-check that the volume is not muted, or something like that?

Finally, if it doesn't help, can you try « sudo apt install pipewire-alsa » then log out and log back in. Does it work?

If it doesn't work: try « sudo apt install firmware-sof-signed » then reboot. Does it work?

Also: did you have the sound working with Kali Linux before, or with another Linux distro? It's possible that your hardware is simply not supported.

Another thing you



2023-05-18 16:52

reporter   ~0017970

Yes, I've tried logging in with non-root, and I made sure I set the volume up. I have done many other methods and it's the same, my laptop doesn't make any sound.

I have tried
« sudo apt install pipewire-alsa »
« sudo apt install firmware-sof-signed »
then log out and log back in.

also does nothing.

yes, I really make sure that the laptop hardware is functioning very well, because I used Kali 2022 before and the speaker sound is there. and also I use dual bot, Windows 11 and yes, the speaker sound is also there. please is there any other way to fix this?

Configuration.png (18,598 bytes)   
Configuration.png (18,598 bytes)   
Input Devices.png (19,977 bytes)   
Input Devices.png (19,977 bytes)   
Output Devices.png (25,322 bytes)   
Output Devices.png (25,322 bytes)   
Playback.png (43,184 bytes)   
Playback.png (43,184 bytes)   
Recording.png (19,312 bytes)   
Recording.png (19,312 bytes)   


2023-05-18 18:47

reporter   ~0017971

i have solved this problem. Thank you to all of you



2023-05-19 01:14

manager   ~0017973

Glad to hear that it works again. I've read the link you gave above, it seems to indicate that installing firmware-sof-signed could fix it, but then it would probably require a full restart, not a log out/ log in. Anyway, I'm closing the ticket. Thanks for following up and telling us what was the solution.

Issue History

Date Modified Username Field Change
2023-05-18 12:30 arif_rahman_umam New Issue
2023-05-18 13:20 daniruiz Assigned To => daniruiz
2023-05-18 13:20 daniruiz Status new => closed
2023-05-18 13:20 daniruiz Resolution open => duplicate
2023-05-18 13:20 daniruiz Relationship added duplicate of 0008299
2023-05-18 14:29 arnaudr Assigned To daniruiz => arnaudr
2023-05-18 14:29 arnaudr Status closed => feedback
2023-05-18 14:29 arnaudr Resolution duplicate => reopened
2023-05-18 14:35 arnaudr Note Added: 0017965
2023-05-18 16:52 arif_rahman_umam File Added: Configuration.png
2023-05-18 16:52 arif_rahman_umam File Added: Input Devices.png
2023-05-18 16:52 arif_rahman_umam File Added: Output Devices.png
2023-05-18 16:52 arif_rahman_umam File Added: Playback.png
2023-05-18 16:52 arif_rahman_umam File Added: Recording.png
2023-05-18 16:52 arif_rahman_umam Note Added: 0017970
2023-05-18 16:52 arif_rahman_umam Status feedback => assigned
2023-05-18 18:47 arif_rahman_umam Note Added: 0017971
2023-05-19 01:14 arnaudr Note Added: 0017973
2023-05-19 01:15 arnaudr Status assigned => resolved
2023-05-19 01:15 arnaudr Resolution reopened => fixed