View Issue Details

IDProjectCategoryView StatusLast Update
0008330Kali Linux[All Projects] General Bugpublic2023-06-01 02:19
Reportertefastein Assigned Toarnaudr  
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0008330: No audio on the laptop
DescriptionI installed Kali since a week as dualboot with win 11 and the audio doesn't work on the laptop, although it works with the bluetooth headset. I tried also alot of solutions, but nothing.
also the solution on the documentation before it comes.

i will be very thankfull, if it works.



2023-05-26 03:03

manager   ~0018020


please open a terminal, type the following commands, and paste the output here:

dpkg -l | grep -E 'blue[tz]|pipewire|wireplumber|pulse|kali-desktop-xfce'

ps -fp $(pgrep wire)

systemctl --user status pipewire.service

systemctl --user status pipewire-pulse.service

systemctl --user status wireplumber.service

Can you also run « sudo apt install -y firmware-sof-signed ». If you see that the package is being installed (meaning it was not installed before), then please reboot and see if it works better.

Also, I suppose that you use the default Kali desktop (XFCE), is it correct? Thanks!


2023-05-26 03:19

reporter   ~0018021


every thing if working ok.

I try to make a note with the output, but i think there is a problem to me.


2023-05-26 03:21

reporter   ~0018022

here is a screenshot with the outputs


2023-05-26 04:32

manager   ~0018023

Did you try « sudo apt install -y firmware-sof-signed » then reboot?


2023-05-26 11:08

reporter   ~0018024

firstly thank you for your reply and your support, arnaudr.

secondly, yes i tried it and nothing happend.


2023-05-26 14:25

manager   ~0018025

Ok, that's becoming difficult now... Can you try « cat /proc/asound/cards » to see what sound cards are detected? Maybe your audio interface is not supported in Linux, it can happen, especially if it's a very recent model of laptop.


2023-05-26 15:34

reporter   ~0018026

ok, let's make it more difficult and say that it is already supported :(


2023-05-26 15:56

reporter   ~0018027

i am not sure, but i think there is a problem with the libcamera


2023-05-26 15:59

reporter   ~0018028

i am also not sure if this can help on something

Screenshot_2023-05-26_17-59-11.png (273,630 bytes)


2023-05-27 06:55

reporter   ~0018031

I have a similar insure
My Dualboot Kali has no sound
But in my case, running <<cat /proc/asound/cards>> gives me --no soundcards--


2023-05-29 02:02

manager   ~0018037

Last edited: 2023-05-29 02:43

View 2 revisions

@tefastein I wouldn't worry about libcamera, I've seen the same error messages on every setup that I checked. Just ignore it.

However, what I see when I type wpctl is slightly different:

└─$ wpctl status
PipeWire 'pipewire-0' [0.3.65, [email protected], cookie:3899416147]
 └─ Clients:
        31. pipewire                            [0.3.65, [email protected], pid:763]
        33. WirePlumber                         [0.3.65, [email protected], pid:762]
        34. WirePlumber [export]                [0.3.65, [email protected], pid:762]
        48. xfce4-pulseaudio-plugin             [0.3.65, [email protected], pid:946]
        49. wpctl                               [0.3.65, [email protected], pid:2892]

Here you can see xfce4-pulseaudio-plugin, while it's not there on your screenshot. Can you check if the process is running? Here's what I get:

└─$ ps fax | grep xfce | grep pulse
    946 ?        Sl     0:00          |   \_ /usr/lib/x86_64-linux-gnu/xfce4/panel/wrapper-2.0
/usr/lib/x86_64-linux-gnu/xfce4/panel/plugins/ 16 16777231
pulseaudio PulseAudio Plugin Adjust the audio volume of the PulseAudio sound system

Also, here's the end of wpctl status for me:

 └─ Default Configured Node Names:
         0. Audio/Sink    alsa_output.pci-0000_00_03.0.analog-stereo
         1. Audio/Source  alsa_input.pci-0000_00_03.0.analog-stereo

While for you, it's bluetooth. You could try to disable buletooth, and then check what appears in « Default Configured Node Names ». Nothing, or alsa devices?


2023-05-29 02:05

manager   ~0018038

@tefastein: Also, I know it sounds stupid, but still: make sure to click on the audio icon (top-right corner of the screen), make sure audio is not muted, volume is up. Open the audio mixer, click around, make sure the right output device is selected, etc...


2023-05-29 02:06

manager   ~0018039

@etmensah: So, did you try to run « sudo apt install -y firmware-sof-signed », then reboot. Any improvement?


2023-05-29 02:41

manager   ~0018040

Last edited: 2023-05-29 02:53

View 3 revisions

@tefastein: There is a very detailed thread on the Linux Mint forum: In this thread, as you'll see, the user AceKing reported the issue, and the user named SMG is the knowledgeable person. Ignore the other posters.

But the conclusion of this thread is just that: sound is simply not supported in Linux for this model of laptop. It will be in the future, hopefully.

If you really have time on your hand, you could try to boot a recent live USB image from another distro, something very recent, maybe the latest Ubuntu, and check if sound works.

But I don't want to waste your time, so I'm not really asking you to do that, just saying it's a possibility.

Feel free to keep investigating and post more feedback here. But at this point I'm afraid that there's nothing more I can do.


2023-05-29 03:47

reporter   ~0018041

@arnaudr: No

Let me do that and get back to you.



2023-05-29 11:53

reporter   ~0018043

Hi @arnaudr,

I think somehow the problem would be at settings of the wireplumber. Although I close the bluetooth service, the Audio/Sink at the wpctl status is still on bluetooth.

I am sure that the audio is not muted.

Btw I solved the libcamera .

Thank you for your support.


2023-05-29 13:19

reporter   ~0018044

@arnaudr: I did exactly what you instructed - run « sudo apt install -y firmware-sof-signed », then reboot.

My sound is working noun.

Thank you. I am very grateful.


2023-05-29 15:43

manager   ~0018045

@tefastein: How did you solve the libcamera error messages?

@etmensah: Glad to hear that it worked!


2023-05-29 16:51

reporter   ~0018046

I think somehow regarding the sound, I must fix the routing for only the audio/sink. But what wounder me that wpctl doesn't read any sink, although the pactl is:
<span style="color:#49AEE6">pactl</span> list short                    
1       libpipewire-module-rt   {
            nice.level    = -11
            #rt.prio      = 88
            #rt.time.soft = -1
            #rt.time.hard = -1
2       libpipewire-module-protocol-native              
3       libpipewire-module-profiler             
5       libpipewire-module-metadata             
7       libpipewire-module-spa-device-factory           
9       libpipewire-module-spa-node-factory             
11      libpipewire-module-client-node          
13      libpipewire-module-client-device                
15      libpipewire-module-portal               
16      libpipewire-module-access       {
            # access.allowed to list an array of paths of allowed
            # apps.
            #access.allowed = [
            #    /usr/bin/pipewire-media-session

            # An array of rejected paths.
            #access.rejected = [ ]

            # An array of paths with restricted access.
            #access.restricted = [ ]

            # Anything not in the above lists gets assigned the
            # access.force permission.
            #access.force = flatpak
17      libpipewire-module-adapter              
19      libpipewire-module-link-factory         
21      libpipewire-module-session-manager              
536870912       module-always-sink              
183     alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_5__sink    PipeWire        s24-32le 2ch 48000Hz    SUSPENDED
184     alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_4__sink    PipeWire        s24-32le 2ch 48000Hz    SUSPENDED
185     alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_3__sink    PipeWire        s24-32le 2ch 48000Hz    SUSPENDED
186     alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink      PipeWire        s32le 2ch 48000Hz       SUSPENDED
183     alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_5__sink.monitor    PipeWire        s24-32le 2ch 48000Hz    SUSPENDED
184     alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_4__sink.monitor    PipeWire        s24-32le 2ch 48000Hz    SUSPENDED
185     alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_3__sink.monitor    PipeWire        s24-32le 2ch 48000Hz    SUSPENDED
186     alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink.monitor      PipeWire        s32le 2ch 48000Hz       SUSPENDED
187     alsa_input.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__source     PipeWire        s24-32le 2ch 48000Hz    SUSPENDED
188     alsa_input.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_6__source   PipeWire        s32le 2ch 48000Hz       SUSPENDED
209     186     103     PipeWire        float32le 2ch 48000Hz
31      PipeWire        pipewire
71      PipeWire        gsd-media-keys
72      PipeWire        gnome-shell
73      PipeWire        xdg-desktop-portal
74      PipeWire        gnome-shell
103     PipeWire        firefox-esr
160     PipeWire        sd_dummy
171     PipeWire        wireplumber
172     PipeWire        wireplumber
215     PipeWire        pactl
0       bell-window-system      s16le 2ch 44100Hz       0.387
178     alsa_card.pci-0000_00_1f.3-platform-skl_hda_dsp_generic alsa

regarding the libcamera :
i reinstalled the libcamera0.0.3 and installed the libcamera-tools, pipewire-libcamera and I am not sure if the libcamera-dev has an effect, but I also installed it.


2023-05-29 16:54

reporter   ~0018047

by the way I installed gnome yesterday, because of some touch screen problems with the xfce and for the
<span style="color:#49AEE6">ps</span> fax <span style="color:#277FFF">|</span> <span style="color:#49AEE6">grep</span> gnome <span style="color:#277FFF">|</span> <span style="color:#49AEE6">grep</span> pulse

I don't get any output


2023-05-29 16:55

reporter   ~0018048

sorry i forgot the main tag
ps fax | grep gnome | grep pulse


2023-05-30 01:25

manager   ~0018049

@tefastein Another think you can try, if you want to rules out pulseaudio- or pipewire-related issues, is just to play via ALSA tools. ALSA is the driver level. If you can't play sound via ALSA, there are good chances that your hardware is not supported.

You need the alsa-utils package, then you can try commands like speaker-test and alsamixer.


2023-05-30 18:11

reporter   ~0018052

I think it is a general case at the envy-laptops.
I found also someone who solved it.
but i face a problem and would be thankfull if you could help me with it.
when i execute his bash file.
Sign command: /usr/lib/linux-kbuild-6.1/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/
readelf: Error: Not an ELF file - it has the wrong magic bytes at the start
readelf: Error: Not an ELF file - it has the wrong magic bytes at the start

Running the pre_build script:
Downloading kernel source 6.1. for 6.1.0-kali9-amd64
--2023-05-30 20:08:32--
Resolving ( 2604:1380:4601:e00::3,
Connecting to (|2604:1380:4601:e00::3|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2023-05-30 20:08:32 ERROR 404: Not Found.

Extracting original source of the kernel module
tar: linux-6.1..tar.*: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
Applying cs35l41_hda.patch
can't find file to patch at input line 3
Perhaps you should have used the -p or --strip option?
The text leading up to this was:
|--- sound/pci/hda/cs35l41_hda.c
|+++ sound/pci/hda/cs35l41_hda.c
File to patch:

If you have an idea, what should i do.


2023-05-31 08:36

manager   ~0018056

@tefastein: Please try my fork, it should be fixed: Please tell me if sound is fixed after that. Thanks!


2023-05-31 09:12

reporter   ~0018057

@arnaudr I got this error also
Building module:
Cleaning build area...
make -j12 KERNELRELEASE=6.1.0-kali9-amd64 -C /lib/modules/6.1.0-kali9-amd64/build M=/var/lib/dkms/snd-hda-codec-realtek/0.1/build....(bad exit status: 2)
Error! Bad return status for module build on kernel: 6.1.0-kali9-amd64 (x86_64)
Consult /var/lib/dkms/snd-hda-codec-realtek/0.1/build/make.log for more information.


2023-05-31 09:16

reporter   ~0018059

the log file says at the end
/bin/sh: 1: ./tools/bpf/resolve_btfids/resolve_btfids: not found
make[1]: *** [/usr/src/linux-headers-6.1.0-kali9-common/scripts/Makefile.modfinal:63: /var/lib/dkms/snd-hda-codec-realtek/0.1/build/snd-hda-codec-cirrus.ko] Error 127
make[1]: *** Deleting file '/var/lib/dkms/snd-hda-codec-realtek/0.1/build/snd-hda-codec-cirrus.ko'
make[1]: *** Waiting for unfinished jobs....
/bin/sh: 1: ./tools/bpf/resolve_btfids/resolve_btfids: not found
make[1]: *** [/usr/src/linux-headers-6.1.0-kali9-common/scripts/Makefile.modfinal:63: /var/lib/dkms/snd-hda-codec-realtek/0.1/build/snd-hda-codec-analog.ko] Error 127
make[1]: *** Deleting file '/var/lib/dkms/snd-hda-codec-realtek/0.1/build/snd-hda-codec-analog.ko'
/bin/sh: 1: ./tools/bpf/resolve_btfids/resolve_btfids: not found
make[1]: *** [/usr/src/linux-headers-6.1.0-kali9-common/scripts/Makefile.modfinal:63: /var/lib/dkms/snd-hda-codec-realtek/0.1/build/snd-hda-codec-ca0110.ko] Error 127
make[1]: *** Deleting file '/var/lib/dkms/snd-hda-codec-realtek/0.1/build/snd-hda-codec-ca0110.ko'
/bin/sh: 1: ./tools/bpf/resolve_btfids/resolve_btfids: not found
make[1]: *** [/usr/src/linux-headers-6.1.0-kali9-common/scripts/Makefile.modfinal:63: /var/lib/dkms/snd-hda-codec-realtek/0.1/build/snd-hda-codec-cmedia.ko] Error 127
make[1]: *** Deleting file '/var/lib/dkms/snd-hda-codec-realtek/0.1/build/snd-hda-codec-cmedia.ko'
/bin/sh: 1: ./tools/bpf/resolve_btfids/resolve_btfids: not found
make[1]: *** [/usr/src/linux-headers-6.1.0-kali9-common/scripts/Makefile.modfinal:63: /var/lib/dkms/snd-hda-codec-realtek/0.1/build/snd-hda-codec-conexant.ko] Error 127
make[1]: *** Deleting file '/var/lib/dkms/snd-hda-codec-realtek/0.1/build/snd-hda-codec-conexant.ko'
make: *** [/usr/src/linux-headers-6.1.0-kali9-common/Makefile:1954: modules] Error 2
make: Leaving directory '/usr/src/linux-headers-6.1.0-kali9-amd64'


2023-05-31 09:19

manager   ~0018060

Yep this is due to the vmlinux file that was copied by the previous version of the script...

Remove it with:

find /usr/src/linux-headers-* -name vmlinux -delete

And then retry.


2023-05-31 09:55

reporter   ~0018061

I am still optimistic that I can find a solution
sudo dmesg | grep cs35l41-hda
[    5.395554] cs35l41-hda i2c-CSC3551:00-cs35l41-hda.0: Cirrus Logic CS35L41 (35a40), Revision: B2
[    5.396381] cs35l41-hda i2c-CSC3551:00-cs35l41-hda.1: Reset line busy, assuming shared reset
[    5.461632] cs35l41-hda i2c-CSC3551:00-cs35l41-hda.1: Cirrus Logic CS35L41 (35a40), Revision: B2

dkms status                  
snd-hda-codec-realtek/0.1, 6.1.0-kali9-amd64, x86_64: installed
snd-hda-scodec-cs35l41/0.1, 6.1.0-kali9-amd64, x86_64: installed

although everything goes ok, but still no sound :(


2023-05-31 10:11

manager   ~0018062

I'm sure you've seen step 3 in

> Step 3. is where you can add your own patches to support your laptop model.

I don't know if that means that you should tweak the patches for your model. I think at this point, the best is to open an issue at, the author can surely help.


2023-05-31 18:56

reporter   ~0018126

Hi @arnaudr,

I am really really really THANKFULL for you and your support.
 I really appreciate your that and thank you for you time.

It works now I didn't take on consideration that I mus change "SND_PCI_QUIRK(0x103c, 0x8a29, "HP Envy x360 15-ew0xxx", ALC287_FIXUP_CS35L41_I2C_2)" to my sound system id at the file.

Thank you so much.


2023-06-01 02:19

manager   ~0018127

Great to hear! Hopefully this model of laptop/soundcard will be supported in the linux kernel in the future.

Also note that, if I'm not mistaken, you might lose sound every time "apt full-upgrade" installs a new kernel... Then you will have to run those scripts again, I guess.

I'm closing the issue then. Thanks to you for following up until the end!

Issue History

Date Modified Username Field Change
2023-05-26 02:26 tefastein New Issue
2023-05-26 03:03 arnaudr Note Added: 0018020
2023-05-26 03:19 tefastein Note Added: 0018021
2023-05-26 03:21 tefastein File Added: Screenshot_2023-05-26_05-20-34.png
2023-05-26 03:21 tefastein File Added: Screenshot_2023-05-26_05-21-16.png
2023-05-26 03:21 tefastein Note Added: 0018022
2023-05-26 04:32 arnaudr Note Added: 0018023
2023-05-26 11:08 tefastein Note Added: 0018024
2023-05-26 14:25 arnaudr Note Added: 0018025
2023-05-26 15:34 tefastein File Added: Screenshot_2023-05-26_17-32-57.png
2023-05-26 15:34 tefastein Note Added: 0018026
2023-05-26 15:56 tefastein File Added: Screenshot_2023-05-26_17-55-34.png
2023-05-26 15:56 tefastein Note Added: 0018027
2023-05-26 15:59 tefastein File Added: Screenshot_2023-05-26_17-58-46.png
2023-05-26 15:59 tefastein File Added: Screenshot_2023-05-26_17-59-11.png
2023-05-26 15:59 tefastein Note Added: 0018028
2023-05-27 06:55 etmensah File Added: Screenshot_2023-05-27_06-54-05.png
2023-05-27 06:55 etmensah Note Added: 0018031
2023-05-29 02:02 arnaudr Note Added: 0018037
2023-05-29 02:05 arnaudr Note Added: 0018038
2023-05-29 02:06 arnaudr Note Added: 0018039
2023-05-29 02:41 arnaudr Note Added: 0018040
2023-05-29 02:42 arnaudr Note Edited: 0018040 View Revisions
2023-05-29 02:43 arnaudr Note Edited: 0018037 View Revisions
2023-05-29 02:53 arnaudr Note Edited: 0018040 View Revisions
2023-05-29 03:47 etmensah Note Added: 0018041
2023-05-29 11:53 tefastein Note Added: 0018043
2023-05-29 13:19 etmensah Note Added: 0018044
2023-05-29 15:43 arnaudr Note Added: 0018045
2023-05-29 16:51 tefastein Note Added: 0018046
2023-05-29 16:54 tefastein Note Added: 0018047
2023-05-29 16:55 tefastein Note Added: 0018048
2023-05-30 01:25 arnaudr Note Added: 0018049
2023-05-30 18:11 tefastein Note Added: 0018052
2023-05-31 08:36 arnaudr Note Added: 0018056
2023-05-31 09:12 tefastein Note Added: 0018057
2023-05-31 09:16 tefastein Note Added: 0018059
2023-05-31 09:19 arnaudr Note Added: 0018060
2023-05-31 09:55 tefastein Note Added: 0018061
2023-05-31 10:11 arnaudr Note Added: 0018062
2023-05-31 18:56 tefastein Note Added: 0018126
2023-06-01 02:19 arnaudr Note Added: 0018127
2023-06-01 02:19 arnaudr Assigned To => arnaudr
2023-06-01 02:19 arnaudr Status new => resolved
2023-06-01 02:19 arnaudr Resolution open => fixed