View Issue Details

IDProjectCategoryView StatusLast Update
0008604Kali LinuxGeneral Bugpublic2024-01-23 03:34
ReporterLexpert Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
Summary0008604: Cannot boot into new iso of Kali but can with older versions

Processor: AMD Ryzen 7 4800H with Radeon Graphics
Nvidia GPU: Nvidia RTX 3050ti

I recently was reinstalling windows and Kali in dual boot and encountered a problem with booting into Kali. Had no problem installing Kali as main OS or in dual boot on this laptop (Asus Rog Strix G15 G513IE) but after reinstalling, after booting in grub (Kali option), I just see black screen with some system messages (refer to 20240122_153517.webp image). So the iso which I tried few times in a row was the latest one (kali-linux-2024-W04-installer-amd64.iso) and after installing and booting I see black screen stated before. Then I tried choosing some older iso (kali-linux-2022.1-installer-everything-amd64.iso) and it booted without problems, everything was just working fine except the fact that I could not install Nvidia drivers with the resulting message which I will also attach (refer to image.webp image). If I try to update + upgrade, I get a random crash, reboot and same black screen with amdgpu system messages.
I decided to get to kali official discord community to figure out whether it is my fault or something. I was suggested to try custom Kali image with some changes (adding nvidia-driver and nvidia-cuda-tool) with live-build-config. It did not help either. Any ideas what could the reason for such system repsonse be ?

Attached Files
image.jpg (586,806 bytes)
20240122_153517.jpg (193,925 bytes)   
20240122_153517.jpg (193,925 bytes)   




2024-01-22 20:52

reporter   ~0018837

Last edited: 2024-01-22 20:54

This issue was reported on Discord earlier today, when the author (Lex) was trying to install nvidia-driver and nvidia-cuda-toolkit on their Kali, but due to the issue above, they were using 2022.1 (IIRC). However, due to the changes made to sources.list with non-free-firmware, they were unable to install the drivers. S3L33 and I suspected that it could be due to the integrated AMD GPU conflicting with nouveau, hence suggested Lex to create a custom ISO with nvidia-driver and nvidia-cuda-toolkit. However, this still didn't fix it for him and at the same time another user came with an identical issue, this time using an ASUS Zephyrus G14.

While I was suspecting something to be wrong with ASUS specifically, @x0rw3ll came up with the idea of adding nomodeset to the kernel boot parameters, which seemed to solve this issue.

If @Lexpert can also confirm that this solves the issue for him, then the next step would be to confirm if both of the users had a deadlock right after amdgpu's fb dev, which is being strongly hinted to be the culprit (initially theorized by @x0rw3ll)

Disable kernel modesetting. Most systems' firmware
sets up a display mode and provides framebuffer memory
for output. With nomodeset, DRM and fbdev drivers will
not load if they could possibly displace the pre-
initialized output. Only the system framebuffer will
be available for use. The respective drivers will not
perform display-mode changes or accelerated rendering.


2024-01-22 20:54

reporter   ~0018838

Courtesy of @x0rw3ll

fbdev.png (49,577 bytes)   
fbdev.png (49,577 bytes)   


2024-01-23 03:34

reporter   ~0018841


Issue History

Date Modified Username Field Change
2024-01-22 20:34 Lexpert New Issue
2024-01-22 20:34 Lexpert File Added: image.jpg
2024-01-22 20:34 Lexpert File Added: 20240122_153517.jpg
2024-01-22 20:52 Arszilla Note Added: 0018837
2024-01-22 20:54 Arszilla Note Edited: 0018837
2024-01-22 20:54 Arszilla Note Added: 0018838
2024-01-22 20:54 Arszilla File Added: fbdev.png
2024-01-23 03:34 Arszilla Note Added: 0018841