View Issue Details

IDProjectCategoryView StatusLast Update
0008611Kali LinuxGeneral Bugpublic2024-01-29 07:00
Reportervanguard Assigned Toarnaudr  
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionopen 
Summary0008611: Building live-build with apt-cacher-ng is crashing

Dear maintainers,

as you might know, I am regularly building my own kali-live using ./

As I do not always want to download all the packages every time, I am using apt-cacher-ng and store all downloaded packages on my harddrive.
This was working for many years, but at about 1-2 years, this is not always working. And I can not find teh reason for it.

The error message at crash is telling, that a package has changed the size or "is there a mirroring in process?"

To get closer, I then deleted the named package, let it download new, and tried again - without success. But: When I delete the whole repository, then it is working.

For me it looks like there is a discrepancy between the package and the file "packages.gz", but I can not prove it.

Of course, it also can be, that I have to configure the environment in another way as before.

This is my actual environment, set by a bash sript (only the apt-cacher-part is interesting here):

------------ snip --------------

export http_proxy=http://localhost:3142/
./ --arch amd64 --distribution kali-rolling --variant lxde --verbose -- --apt-http-proxy http://localhost:3142/ --bootappend-live "boot=live hostname=kali ignore.....................


--------- snap -------------

Before you ask: I am building in a kali-live system, so I have to copy another acng.conf to /etc, and restart apt-cacher-ng before building. This is also done by my bash script.

Today I had the problem again, this time it mourned the size of packages.gz, strangely one of /root/packages.gz, but also of the repository

I am not sure, if this is a bug here on my computer, or in the repo itself or hust unlucky constellations. But as I said, this issue is appearing from time to time and although I have nothing changed, almost since 1-2 years.

What can I do other than sending the build.log, which does not tell much usefull information?

It would be nice, if one could confirm, that apt-cacher-ng is still usable for my needs and/or if I have to change my configuration.

Thank you all in advance.






2024-01-29 07:00

manager   ~0018864


I also use apt-cacher-ng, it fails me quite often, but I never had time to troubleshot. When it fails, I remove the dists directory in the cache, eg: rm -fr /var/cache/apt-cacher-ng/klxrep/dists/. That's enough to fix it.

Issue History

Date Modified Username Field Change
2024-01-27 15:51 vanguard New Issue
2024-01-28 07:24 steev Assigned To => arnaudr
2024-01-28 07:24 steev Status new => assigned
2024-01-29 07:00 arnaudr Note Added: 0018864