View Issue Details

IDProjectCategoryView StatusLast Update
0008670Kali LinuxGeneral Bugpublic2024-03-15 18:27
ReporterPulkit_garg Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
Summary0008670: Problems Encountered with Kali Linux Installation on HP Victus 15 FB1001AX

This report aims to document and address several issues encountered while running Kali Linux as the primary operating system on the HP Victus 15 FB1001AX laptop. The issues include non-functioning microphones, unresponsive screen brightness controls, and difficulty connecting any Bluetooth devices.

Hardware Information:

Laptop Model: HP Victus 15 FB1001AX
Processor: AMD Ryzen™ 5 7535HS (up to 4.55 GHz maximum boost clock, 16 MB L3 cache, 6 cores, and 12 threads)
RAM: 16 GB DDR5-4800 MHz RAM (2 x 8 GB)
Graphics Card: NVIDIA® GeForce RTX™ 2050 Laptop GPU (4 GB GDDR6 dedicated)
Wireless Adapter: MediaTek MT7921 Wi-Fi 6 802.11ax (2x2) multi-user MIMO supported
Bluetooth Adapter: Bluetooth® 5.3 (supporting gigabit data rate)
Display information: 39.6 cm (15.6 in) diagonal, FHD (1920 x 1080), 144 Hz, IPS, micro-edge, antiglare, 250 nits, 45% NTSC
Software Information:
Operating System: Kali Linux 2024.1
Kernel Version: 6.6.9-amd64 (64-bit)
Desktop Environment: Kde Plasma version 5.27.10

Problem Description:

Microphone Not Working:

Symptoms: The microphone does not capture any audio input, making it impossible to use for voice recording, video calls, or any other audio-related tasks.
Steps Taken: Attempted to configure audio settings through system preferences and alsamixer, but no success.
Expected Behavior: The microphone should be detected and functional without requiring additional configurations.

Screen Brightness Control Not Functional:

Symptoms: The brightness controls (both keyboard shortcuts and system settings) do not alter the screen brightness levels.
Steps Taken: Tried adjusting brightness settings through system preferences and command-line utilities, but no change observed.
Expected Behavior: The user should be able to adjust screen brightness levels using the designated controls.

Difficulty Connecting Wireless Bluetooth Earphones:

Symptoms: Wireless Bluetooth earphones fail to connect to the laptop, even after multiple attempts.
Steps Taken: Ensured Bluetooth service is running, attempted to pair the earphones using the GUI and command-line tools, but the connection was unsuccessful.

Expected Behavior: The laptop should be able to pair and connect with Bluetooth devices seamlessly.
"br-connection-profile-unavailable" Error When Connecting Realme Buds Air 3, My phone also :
Symptoms: When attempting to pair Realme Buds Air 3 wireless earphones, the error message "br-connection-profile-unavailable" is displayed, preventing successful connection.
Steps Taken: Tried various troubleshooting steps, including restarting Bluetooth service, re-pairing the device, and checking for any available updates, but the issue persists.
Expected Behavior: The Realme Buds Air 3 earphones should pair successfully and connect without encountering any errors.

Additional Information:

It's important to note that these issues were not encountered while using other operating systems on the same hardware.
No recent changes or updates were made to the system prior to the emergence of these issues.
Request for Further Assistance:
To assist in resolving these issues effectively, I would appreciate guidance on any additional diagnostic steps or troubleshooting procedures that could be undertaken. Additionally, please advise if there are any specific logs or system information that would be helpful in diagnosing these problems further.

Thank you for your attention to these matters. I look forward to your prompt response and resolution of these issues.




2024-03-15 18:27

manager   ~0019039

Thank you for such a well organized report! I just have one question about the other operating systems you tried; did you try Debian? What about other desktop environments, do any of these issues appear in Xfce or GNOME? What about on Debian with various environments?

We don't have the hardware capability to work through these problems ourself, but with your assistance we may be able to get a good idea about where the problem lies. Log files would be helpful as well:

Issue History

Date Modified Username Field Change
2024-03-15 06:35 Pulkit_garg New Issue
2024-03-15 18:27 Gamb1t Note Added: 0019039