View Issue Details

IDProjectCategoryView StatusLast Update
0008748Kali LinuxGeneral Bugpublic2024-05-05 05:26
Reportervanguard Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
Summary0008748: Kali-2024.1 32-Bit: several issues with installation (workarounds included)

Dear maintainers,

although I believe not many people are using 32-bit kali any more and although I heard, 32-bit kali will be abandoned in the future,
I despite want to tell you about some issues I fell into with the installation.

The hardware I installed is a Fujitsu notebook, 8GB RAM and Intel I3 cpu with inbuilt graphics card.

I did several installations and always used the completeharddrive.

Install media was an usb-stick, I wrote the installer image on by using the dd command.

The issues (minor and bigger)

Issue 1: By chosing "Graphical installation" it did not show the graphical menu. I had to boot several times, until it shows the graphical scene. After this, the process went through flawlessly.

Issue 2: After the install process, I had to reboot. The first reboot always fails, but when switching the notebook completely off and on, it shows the grub boot menu and is tsarting to boot.

Issue 3: After the boot starts, the screen goes blank. Nothing is to be seen. I guess, the reason is a uncomfortable resolution, that can not be used.
Workaround 1:
In kernel param remove "quiet splash" and set "vga=791", thus is setting vesamode to 1024x768 and is showing what happens.

Issue 4: When it is now booting, and izt comes to starting X, the screen again is going black and the notebook hangs. Neither switching to a console (CTL + ALT + 2) nor switching off with the power button works. You have to long press the power button, to switch off the system.
Workaround 2:
Install kali-32-bit without any tasks, during installation unset all tasks. Then reboot and like above remove "quiet" and set "vga=791". Now you can enter the system and become root.
Now first of all upgrade the whole system (maybe this is no necessary step, but I recommend this).
After upgrade reboot again. Login, become root and install the package "kali-task-xfce" and "task-<your-language<"and "task-<your-language>-desktop".
When done, remove /sbin/lightdm (or the binary of your preferred login-manager) away, for example to /root.

Now you can reboot again. Again login, become root and check, if X is starting by using the command "startx". If the screen gets blank and you see the mouse pointer, eerything is ok. Then you can move lightdm back and reboot.

If it does NOT working and you can see no mouse-pointer and the screen hangs again )and has to power-off hardly) , then reboot again.
After reboot, become root and copy the file "xorg.conf" from "/usr/share/doc/xserver-xorg-intel-vga/" to "/etc/X11/" and do "startx" again.

Now you should see a blank screen and a mouse-pointer. If so, move lightdm back and reboot.

Evrything should work now!

Have fun!


P.S. Maybe there is a better way, but doing as decribed above, worked for me perfectly. However, improvements are welcome!


There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2024-05-04 13:05 vanguard New Issue