View Issue Details

IDProjectCategoryView StatusLast Update
0008809Kali LinuxGeneral Bugpublic2024-07-01 14:18
Reportercoc Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
Summary0008809: w button not working in french ch layout

My w key is not working at all in kali, (i'm pasting the key each time).
I've figured out that the problem is related to the graphic interface, the problem is here with Default Xsession and Xfce Session. When i swapped to kde it worked directly.
The problem is that the key isnt bind i've figured it out using xev, the screenshots below demonstrates it
We can see it with the command "sudo showkeys --keycodes" too.
And as i explained earlier, as the key works properly using kde, i know the key isnt broken. + if i do "meta + w" with my keyboard, it makes a "w", even if in the qterminal these keys combination makes "sw", for some reason.

Thanks in advance for feedback and if i can answer to any questions feel free to ask.

Attached Files
xev_w_display.png (78,370 bytes)   
xev_w_display.png (78,370 bytes)   
show_keys_display.png (5,455 bytes)   
show_keys_display.png (5,455 bytes)   


Issue History

Date Modified Username Field Change
2024-07-01 14:18 coc New Issue
2024-07-01 14:18 coc File Added: xev_w_display.png
2024-07-01 14:18 coc File Added: show_keys_display.png