View Issue Details

IDProjectCategoryView StatusLast Update
0000891Kali Linux[All Projects] New Tool Requestspublic2014-01-10 20:16
Reporterdookie Assigned Todookie  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0.7Fixed in Version1.0.7 
Summary0000891: Add the Capstone Disassembly Framework
Descriptionhttp://www.capstone-engine.org/index.html

Capstone is a lightweight multi-platform, multi-architecture disassembly framework.

This isn't a particular tool but it's what you would use to create other tools and it's got some smart folks involved with it.

    Support hardware architectures: ARM, ARM64 (aka ARMv8), Mips & X86 (more details).

    Clean/simple/lightweight/intuitive architecture-neutral API.

    Provide details on disassembled instruction (called “decomposer” by others).

    Provide some semantics of the disassembled instruction, such as list of implicit registers read & written.

    Implemented in pure C language, with bindings for Python, Ruby, OCaml, C#, Java and GO available.

    Native support for Windows & *nix (including MacOSX, Linux, *BSD platforms).

    Thread-safe by design.

    Distributed under the open source BSD license.

Activities

dookie

2014-01-10 20:16

administrator   ~0001334

Added in capstone_1.0-1kali0.

Issue History

Date Modified Username Field Change
2014-01-10 17:34 dookie New Issue
2014-01-10 17:34 dookie Status new => assigned
2014-01-10 17:34 dookie Assigned To => dookie
2014-01-10 20:16 dookie Note Added: 0001334
2014-01-10 20:16 dookie Status assigned => resolved
2014-01-10 20:16 dookie Fixed in Version => 1.0.7
2014-01-10 20:16 dookie Resolution open => fixed