View Issue Details

IDProjectCategoryView StatusLast Update
0003135Kali Linux[All Projects] Kali Package Bugpublic2016-03-14 09:24
Reportercrash Assigned Torhertzog  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version 
Summary0003135: Arachni 1.4 error after install
DescriptionArachni 1.4 error after install
Steps To Reproduceroot@Anubis:~# apt-get install arachni
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  arachni
0 upgraded, 1 newly installed, 0 to remove and 59 not upgraded.
Need to get 0 B/1,766 kB of archives.
After this operation, 7,903 kB of additional disk space will be used.
Selecting previously unselected package arachni.
(Reading database ... 318464 files and directories currently installed.)
Preparing to unpack .../arachni_1.4-0kali1_all.deb ...
Unpacking arachni (1.4-0kali1) ...
Setting up arachni (1.4-0kali1) ...
root@Anubis:~# arachni
/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- msgpack/msgpack (LoadError)
    from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/lib/ruby/vendor_ruby/msgpack.rb:11:in `rescue in <top (required)>'
    from /usr/lib/ruby/vendor_ruby/msgpack.rb:8:in `<top (required)>'
    from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/share/arachni/lib/arachni/rpc/serializer.rb:9:in `<top (required)>'
    from /usr/share/arachni/lib/arachni/report.rb:9:in `require_relative'
    from /usr/share/arachni/lib/arachni/report.rb:9:in `<top (required)>'
    from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/share/arachni/lib/arachni/framework.rb:35:in `<module:Arachni>'
    from /usr/share/arachni/lib/arachni/framework.rb:17:in `<top (required)>'
    from /usr/share/arachni/lib/arachni.rb:103:in `require_relative'
    from /usr/share/arachni/lib/arachni.rb:103:in `<top (required)>'
    from /usr/share/arachni/ui/cli/framework.rb:9:in `require_relative'
    from /usr/share/arachni/ui/cli/framework.rb:9:in `<top (required)>'
    from ./arachni:10:in `require_relative'
    from ./arachni:10:in `<main>'
Additional Informationroot@Anubis:~# uname -a
Linux Anubis 4.4.0-kali1-amd64 0000001 SMP Debian 4.4.2-3kali1 (2016-02-23) x86_64 GNU/Linux

root@Anubis:~# ruby -v
ruby 2.3.0p0 (2015-12-25) [x86_64-linux-gnu]

root@Anubis:~# cat /etc/apt/sources.list
#

# deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160120-18:14]/ kali-rolling contrib main non-free

#deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160120-18:14]/ kali-rolling contrib main non-free

deb http://http.kali.org/kali kali-rolling main non-free contrib
# deb-src http://http.kali.org/kali kali-rolling main non-free contrib

root@Anubis:~# cat /etc/issue
Kali GNU/Linux Rolling \n \l

VMware Instalation

Activities

g0tmi1k

2016-03-11 11:57

administrator   ~0004838

Can confirm

rhertzog

2016-03-11 12:38

administrator   ~0004839

Duh, ruby switched to version 2.3 without us noticing... I had to rebuild a few ruby packages against this new ruby version.

Should be fixed with ruby-msgpack 0.7.4-0kali3+b1.

crash

2016-03-14 09:21

reporter   ~0004849

Fixed after update today (14/03/2016)

root@Anubis:~# arachni -v
Arachni - Web Application Security Scanner Framework v1.4
   Author: Tasos "Zapotek" Laskos <tasos.laskos@arachni-scanner.com>

           (With the support of the community and the Arachni Team.)

   Website: http://arachni-scanner.com
   Documentation: http://arachni-scanner.com/wiki


Arachni 1.4 (ruby 2.3.0p0) [x86_64-linux-gnu]

rhertzog

2016-03-14 09:24

administrator   ~0004850

Thanks, closing the ticket.

Issue History

Date Modified Username Field Change
2016-03-11 11:39 crash New Issue
2016-03-11 11:57 g0tmi1k Note Added: 0004838
2016-03-11 12:38 rhertzog Note Added: 0004839
2016-03-14 09:21 crash Note Added: 0004849
2016-03-14 09:24 rhertzog Note Added: 0004850
2016-03-14 09:24 rhertzog Status new => resolved
2016-03-14 09:24 rhertzog Resolution open => fixed
2016-03-14 09:24 rhertzog Assigned To => rhertzog