2017-12-17 10:03 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003293Kali Linux[All Projects] General Bugpublic2016-08-29 16:07
Reporterajukilibodin 
Assigned Torhertzog 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Product Versionkali-dev 
Target VersionFixed in Version2016.2 
Summary0003293: Fonts are corrupted, seeing squares instead of characters
DescriptionAfter an upgrade. Fonts are bugged and are appearing as squares in certain places
Steps To Reproduceapt-get update and upgrade
Additional InformationOther users are having the same issue

https://forums.kali.org/showthread.php?31031-GNOME-visual-issues-after-updating-upgrading-Kali-Rolling
https://forums.kali.org/showthread.php?31025-Problems-with-Text-after-newinstall-and-Update
Attached Files

-Relationships
has duplicate 0003295closedrhertzog Title bars show little square boxes 
has duplicate 0003376closedrhertzog Missing fonts during/after upgrade 
+Relationships

-Notes

~0005247

n0x00 (reporter)

apt --reinstall install fonts-cantarell

~0005248

UNATCO (reporter)

Had the same text problem after that upgrade and tried apt --reinstall install fonts-cantarell with a restart to no avail. This morning several upgrades were pushed (apt-get update && apt-get upgrade && apt-get dist-upgrade) followed by a restart. This seemed to fix the issue.

~0005254

Anseztor (reporter)

apt --reinstall install fonts-cantarell (worked for me)

~0005410

rhertzog (administrator)

I ended up filing a bug on the Debian side: https://bugs.debian.org/828037

~0005530

rhertzog (administrator)

I have uploaded fontconfig 2.11.0-6.5~kali1 with a patch that should forbid fontconfig from registering .dpkg-tmp files. Let's see if we stop getting bug reports. If anyone is able to provide a clean way to reproduce the issue, then please check if this fixes the problem.

~0005629

jlevitsk (reporter)

apt --reinstall install fonts-cantarell (worked for me)

I saw this issue arise from a stock install of Kali 64bit 2016.1 where I ran the package updater app. I installed all updates and the font issue happened. Previously I installed the same install but enabled the bleeding edge updates before my updates and did not experience the problem on the same laptop. On this laptop I thought maybe I'd enable bleeding edge but that didn't resolve the font issue. Once I had the issue the apt command that was posted resolved the issue.

~0005696

rhertzog (administrator)

This should be definitely resolved with fontconfig 2.11.0-6.7 which will be shortly available in Kali.
+Notes

-Issue History
Date Modified Username Field Change
2016-05-15 01:14 ajukilibodin New Issue
2016-05-15 12:17 n0x00 Note Added: 0005247
2016-05-15 14:57 UNATCO Note Added: 0005248
2016-05-17 02:51 Anseztor Note Added: 0005254
2016-05-18 07:09 g0tmi1k Relationship added has duplicate 0003295
2016-06-24 08:55 rhertzog Note Added: 0005410
2016-06-24 08:55 rhertzog Assigned To => rhertzog
2016-06-24 08:55 rhertzog Status new => assigned
2016-06-24 08:58 rhertzog Relationship added has duplicate 0003376
2016-07-11 08:48 rhertzog Summary Fonts are corrupted => Fonts are corrupted, seeing squares instead of characters
2016-07-12 10:16 rhertzog Note Added: 0005530
2016-08-16 22:58 jlevitsk Note Added: 0005629
2016-08-29 16:07 rhertzog Note Added: 0005696
2016-08-29 16:07 rhertzog Status assigned => resolved
2016-08-29 16:07 rhertzog Fixed in Version => 2016.2
2016-08-29 16:07 rhertzog Resolution open => fixed
+Issue History