View Issue Details

IDProjectCategoryView StatusLast Update
0004162Kali Linux[All Projects] General Bugpublic2017-08-25 22:03
Reporterandreashoi@hotmail.comAssigned Torhertzog 
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versionkali-dev 
Target VersionFixed in Version2017.2 
Summary0004162: Suddenly my gnome-terminal got a bug that shows a sill around the terminal
DescriptionSuddenly my gnome-terminal got a bug that shows a sill around the terminal.

When I enter the desktop at boot the terminal on the left shows the same picture with the sill as when I open it. If I open a terminal through right-clicking on the Desktop I get a gnome terminal that works normal, and when I type "gnome-terminal" in it, I get an error message saying: Warning: DESKTOP_STARTUP_ID not set and no fallback available.

I have tried to remove the gnome-terminal and install it again, but it has no different effect. I don't got a clue on how to fix it.

I'm using the amd64 ISO as a main OS, it is fully updated with apt-get update, upgrade and dist-upgrade.

Relationships

duplicate of 0004159 resolvedrhertzog Screen resizing no longer works after recent package upgrade 

Activities

andreashoi@hotmail.com

andreashoi@hotmail.com

2017-08-18 17:09

reporter  

Screenshot from 2017-08-18 19-03-59.png (1,179,686 bytes)
atdtphreaker

atdtphreaker

2017-08-18 20:28

reporter   ~0007027

I too, am experiencing this issue.


Thanks.
atdtphreaker

atdtphreaker

2017-08-18 20:50

reporter   ~0007028

Also, I checked my Kali Live USB (with persistence) to see if it too was having the same problem, BUT on it, the terminal doesn't even come up (just spins and then closes).

In addition, I checked to see if adjusting the "Region/Language" settings would resolve it... But after amending and restarting to logout/log back in, the process freezes. Upon rebooting the Kali Live USB (with persistence) found that it hadn't been changed and the terminal continues to NOT open.

So BOTH Kali-rolling hard disk AND live usb are buggy following update/upgrade.



Thank you.
radualexandrupopescu

radualexandrupopescu

2017-08-19 02:08

reporter   ~0007030

Not an expert, but might be related to https://bugs.kali.org/view.php?id=4159 in the sense that for some reason GNOME defaults to Wayland instead of Xorg.
This should be easy to test: when you log in, after selecting the user (and before inputting the password) you should find a "cog" button near the "Sign in" button; when you click it, a menu appears - choose "GNOME on Xorg"; continue login procedure.
atdtphreaker

atdtphreaker

2017-08-19 03:13

reporter   ~0007031

@radualexandrupopescu

Yes, that seems to have fixed it temporarily. But then I'm having to RE-set it on each boot.



Thanks.
radualexandrupopescu

radualexandrupopescu

2017-08-19 03:50

reporter   ~0007032

@atdtphreaker you can set WaylandEnable=false under [daemon] section of /etc/gdm3/daemon.conf as per @cnn comment in the linked bug above.
atdtphreaker

atdtphreaker

2017-08-19 04:47

reporter   ~0007033

@radualexandrupopescu

Indeed, seems to have solved the issue. Thanks for your insight.
andreashoi@hotmail.com

andreashoi@hotmail.com

2017-08-19 06:57

reporter   ~0007034

That solved the issue, thank you very much!
radualexandrupopescu

radualexandrupopescu

2017-08-19 21:19

reporter   ~0007047

Just keep in mind this is a band-aid and not a fix really, since GNOME is moving towards Wayland.
rhertzog

rhertzog

2017-08-21 16:22

administrator   ~0007058

Closing as duplicate of 0004159.
rhertzog

rhertzog

2017-08-22 11:58

administrator   ~0007071

Re-opening since it's a different issue than 4159.
j_jito

j_jito

2017-08-22 13:04

reporter   ~0007073

Or, if you want to stay on Wayland, go in the terminal setting, uncheck the transparent backgruond.

I had the same issue, but when I unchecked the transparent background, the sill has gone.
rhertzog

rhertzog

2017-08-22 13:57

administrator   ~0007074

This should be fixed with gnome-terminal 3.22.2-1kali3 that I just uploaded.

Issue History

Date Modified Username Field Change
2017-08-18 17:09 andreashoi@hotmail.com New Issue
2017-08-18 17:09 andreashoi@hotmail.com File Added: Screenshot from 2017-08-18 19-03-59.png
2017-08-18 20:28 atdtphreaker Note Added: 0007027
2017-08-18 20:50 atdtphreaker Note Added: 0007028
2017-08-19 02:08 radualexandrupopescu Note Added: 0007030
2017-08-19 03:13 atdtphreaker Note Added: 0007031
2017-08-19 03:50 radualexandrupopescu Note Added: 0007032
2017-08-19 04:47 atdtphreaker Note Added: 0007033
2017-08-19 06:57 andreashoi@hotmail.com Note Added: 0007034
2017-08-19 21:19 radualexandrupopescu Note Added: 0007047
2017-08-21 16:22 rhertzog Assigned To => rhertzog
2017-08-21 16:22 rhertzog Status new => closed
2017-08-21 16:22 rhertzog Resolution open => fixed
2017-08-21 16:22 rhertzog Note Added: 0007058
2017-08-21 16:22 rhertzog Relationship added duplicate of 0004159
2017-08-22 11:58 rhertzog Status closed => confirmed
2017-08-22 11:58 rhertzog Note Added: 0007071
2017-08-22 13:04 j_jito Note Added: 0007073
2017-08-22 13:57 rhertzog Status confirmed => resolved
2017-08-22 13:57 rhertzog Fixed in Version => 2017.2
2017-08-22 13:57 rhertzog Note Added: 0007074