2017-11-18 12:16 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004159Kali Linux[All Projects] General Bugpublic2017-08-29 08:56
Reporterzoneranger 
Assigned Torhertzog 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version2017.1 
Target VersionFixed in Version2017.2 
Summary0004159: Screen resizing no longer works after recent package upgrade
DescriptionI performed an apt-get upgrade && apt-get dist-upgrade recently on a stable Kali VM.
Upon rebooting, I can no longer resize the Gnome window so am stuck with a small resolution in the middle of the screen.
I've tried rebooting with older kernels so it's not 4.11 specific.
I've tried reinstalling open-vm-tools and open-vm-tools-desktop.

This is on VMware Workstation 12.5.7.

This seems identical to the issue reported on the forum by flex-lm:
https://forums.kali.org/showthread.php?30917-Resolution-change-fails-on-ESXi-6-0-VM

Any suggestions gratefully received.
Steps To ReproduceUpdate Gnome Kali on VMware Workstation.
Attached Files
  • png file icon 1.png (23,023 bytes) 2017-08-18 16:12 -
    png file icon 1.png (23,023 bytes) 2017-08-18 16:12 +

-Relationships
has duplicate 0004163closedrhertzog open-vm-tools no longer works after update to 2:10.1.10-1 
has duplicate 0004162resolvedrhertzog Suddenly my gnome-terminal got a bug that shows a sill around the terminal 
has duplicate 0004184closedrhertzog open-vm-tools-desktop 
+Relationships

-Notes

~0007010

kl (reporter)

I have the same issue. One of my colleagues too.

I am running VMware Fusion 8.5.8 (5824040)

Also tried to use the pre-made image for VMware. Resizing and auto-fit works. After updating, it's broken and does not work anymore. You can, however, set a custom display resolution manually.

Screenshot: http://i.imgur.com/9iLehQu.png

(Also notice the outline behind the Terminal window - this is also occuring after the update).

~0007011

zoneranger (reporter)

kali:~$ xrandr -q
Screen 0: minimum 320 x 200, current 800 x 600, maximum 8192 x 8192
XWAYLAND0 connected 800x600+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   800x600 59.86*+

Trying to force this to say, 1920x1080 returns:
kali:~$ xrandr --output XWAYLAND0 --mode 1920x1080
xrandr: cannot find mode 1920x1080

~0007012

kl (reporter)

Changing resolution works with the "Displays" application for me.

~0007013

zoneranger (reporter)

Thanks kl - I can now at least see some more of the screen - those weird extra boxes around terminal windows are very noticeable though.

My host OS (Windows 7) is at 1920x1080 - it just appears this mode has disappeared so I'm on 1920x1200 at the moment using the Displays application.

Is this a fundamental change in supported modes, or a GNOME specific theme change, or something else?

~0007014

kl (reporter)

I am not sure. I must leave the answer to that questions to the pros ;-)

~0007019

rhertzog (administrator)

From the xrandr output, I can infer that you are using Waylant and not Xorg. You might want to try to switch back to Xorg. This should be doable at the login screen by selecting the Gnome session instead of the Gnome Wayland one.

~0007021

zoneranger (reporter)

Thanks - that has fixed the problem.
I can see from xrandr I now have all the expected resolutions.

After reboot from update it must have fallen back to 'System X11 Default' for whatever reason - I have never touched that menu (window manager choice) since installing Kali from iso so I'm still presuming some update has caused this.

Very happy to see it back to normal, though!

~0007022

zoneranger (reporter)

Just to add a screen-shot - these are the options I have present.
I've never chosen/installed a Gnome Wayland option so possibly some package is defaulting to assuming I have it installed and it falls back to default X11 when it isn't there?

~0007024

cnn (reporter)

Same issue here, but thanks to rhertzog it worked.

However this setting isn't kept after a reboot, so I had to disable Wayland in the [daemon] section of /etc/gdm3/daemon.conf with:
WaylandEnable=false

~0007026

radualexandrupopescu (reporter)

I also encountered this issue; fixed by switching to Xorg at login as rhertzog mention.
Can't really recall when I saw Wayland getting pulled on update.

~0007029

kl (reporter)

I can confirm switching to Xorg works.

~0007038

rhertzog (administrator)

So I confirm that Gnome recently switched to use Wayland by default and that we should now select Xorg manually if we have a reason to switch back. We can probably switch the default back to Xorg but it's not going to be a long term solution.

We should get VMWare/its video driver/open-vm-tools fixed to work properly on Wayland too.

~0007039

rhertzog (administrator)

It seems to be reported upstream already:
https://github.com/vmware/open-vm-tools/issues/22

~0007041

rhertzog (administrator)

In the upstream ticket, there's an open question. Do you have a vmtoolsd process running ? (I guess so)

Does it help if you run vmware-user-suid-wrapper ?

~0007046

radualexandrupopescu (reporter)

@rhertzog yes vmtoolsd is running both when using Xorg and Wayland.
Regarding vmware-user-suid-wrapper, it does not seem to work in either case with the error "vmware-user: could not open /proc/fs/vmblock/dev"
I made some screenshots (vmware window mode 800x600 for consistency) of vmware* commands ran when using Wayland and Xorg: https://imgur.com/a/YlKJs (first one is Wayland - you can tell by the extra window/border around the terminal window). The interesting thing seems to be the missing VMWARE_CTRL extension missing when running Wayland.

~0007049

radualexandrupopescu (reporter)

@rhertzog this might be a slightly more broad issue regarding open-vm-tools as reported by @sn0wfa11 here https://bugs.kali.org/view.php?id=4163 (sorry I don't know how to link bug ids like names with the "at" sign)

~0007056

rhertzog (administrator)

Apparently Fedora has a patch for this, I just uploaded open-vm-tools 10.1.10-1kali1 with the same patch. Can you try again with the newer open-vm-tools and report back how it works ? Thank you.

~0007061

radualexandrupopescu (reporter)

@rhertzog I just upgraded and it does not work for me. Not sure if it does not work or if I'm an edge case.


root@kali:~# apt update -qq && apt policy open-vm-tools
All packages are up to date.
open-vm-tools:
  Installed: 2:10.1.10-1kali1
  Candidate: 2:10.1.10-1kali1
  Version table:
 *** 2:10.1.10-1kali1 500
        500 https://http.kali.org/kali kali-rolling/main amd64 Packages
        100 /var/lib/dpkg/status
root@kali:~#

~0007062

radualexandrupopescu (reporter)

@rhertzog also I don't think bug id 0004162 is related since, the reporter @ andreashoi@hotmail.com said he/she is using Kali as a main OS. In this case it would be more of a GNOME/Wayland thing imho.

~0007069

rhertzog (administrator)

@raradualexandrupopescu Did you update open-vm-tools-desktop and open-vm-tools-dkms too? Did you reboot after the update (to ensure you have the latest version of the kernel module)?

~0007077

radualexandrupopescu (reporter)

@rhertzog I did reboot several times.
As for open-vm-tools-dkms, it is not installed on my system:

root@kali:~# apt update -qq && apt policy open-vm-tools*
All packages are up to date.
open-vm-tools-desktop:
  Installed: 2:10.1.10-1kali1
  Candidate: 2:10.1.10-1kali1
  Version table:
 *** 2:10.1.10-1kali1 500
        500 https://http.kali.org/kali kali-rolling/main amd64 Packages
        100 /var/lib/dpkg/status
open-vm-tools-dkms:
  Installed: (none)
  Candidate: 2:10.1.10-1kali1
  Version table:
     2:10.1.10-1kali1 500
        500 https://http.kali.org/kali kali-rolling/main amd64 Packages
     2:10.1.5-5055683-4 -1
        100 /var/lib/dpkg/status
open-vm-tools:
  Installed: 2:10.1.10-1kali1
  Candidate: 2:10.1.10-1kali1
  Version table:
 *** 2:10.1.10-1kali1 500
        500 https://http.kali.org/kali kali-rolling/main amd64 Packages
        100 /var/lib/dpkg/status
open-vm-tools-desktop-dbgsym:
  Installed: (none)
  Candidate: 2:10.1.10-1kali1
  Version table:
     2:10.1.10-1kali1 500
        500 https://http.kali.org/kali kali-rolling/main amd64 Packages
open-vm-tools-dev:
  Installed: (none)
  Candidate: 2:10.1.10-1kali1
  Version table:
     2:10.1.10-1kali1 500
        500 https://http.kali.org/kali kali-rolling/main amd64 Packages
open-vm-tools-dbgsym:
  Installed: (none)
  Candidate: 2:10.1.10-1kali1
  Version table:
     2:10.1.10-1kali1 500
        500 https://http.kali.org/kali kali-rolling/main amd64 Packages
root@kali:~#

although

root@kali:~# apt list open-vm-tools*
Listing... Done
open-vm-tools/kali-rolling,now 2:10.1.10-1kali1 amd64 [installed,automatic]
open-vm-tools-dbgsym/kali-rolling 2:10.1.10-1kali1 amd64
open-vm-tools-desktop/kali-rolling,now 2:10.1.10-1kali1 amd64 [installed]
open-vm-tools-desktop-dbgsym/kali-rolling 2:10.1.10-1kali1 amd64
open-vm-tools-dev/kali-rolling 2:10.1.10-1kali1 amd64
open-vm-tools-dkms/kali-rolling 2:10.1.10-1kali1 all [residual-config]

says it was installed at some point. I presume somewhere along the upgrade path it became unmarked as a dependency for open-vm-tools-desktop and running apt autoremove got rid of it. I suspect somewhere around version 10.1.5.

root@kali:~# apt purge open-vm-tools-dkms
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  open-vm-tools-dkms*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 518036 files and directories currently installed.)
Purging configuration files for open-vm-tools-dkms (2:10.1.5-5055683-4) ...
root@kali:~#

Also, according to 'apt show open-vm-tools-dkms':

 This package provides the source code for the vmxnet module, which was
 superseded by vmxnet3. You should only install this package if you know
 that you need the legacy vnxnet module.
 Kernel source or headers are required to compile it using DKMS.

~0007081

rhertzog (administrator)

I installed a Windows machine with VMWare Workstation Pro and I tried by myself. With open-vm-tools-desktop 2:10.1.10-1kali1 I can use the "View > Fit guest now" menu or enable "View > Autosize > Autofit guest" and the size of my graphical desktop does change, even under Wayland.

For me, this issue is fixed or I did not understand the request at all.

(open-vm-tools-dkms is effectively not needed, I had only open-vm-tools-desktop and open-vm-tools installed)

~0007090

radualexandrupopescu (reporter)

@rhertzog then I must have encountered an edge case because it does not work on my end. The "View > Fit guest now" is always disabled, but when I login with GNOME on X11 the screen just auto-resizes; on Wayland it does not: https://youtu.be/VU16tcMqff8

It doesn't bother me all that much beyond the fact that it annoys me I can't figure out why it does not work for me. Quite curious if it works for everyone else.

If I'm the only one still having issues I don't mind if you close the bug.

~0007099

rhertzog (administrator)

@radualexandrupopescu On IRC someone told me that when you select "System X11 Default" it works (that's what I tested since that's the default) but that it would not work when you select "GNOME". Maybe you selected GNOME?

Though it does not make much sense to have a difference here.

~0007100

rhertzog (administrator)

Hum, trying again, it looks like "System X11 default" is still running Xorg so that explains why it works. I must continue my investigations.

~0007105

cnn (reporter)

Thanks @rhertzog for trying but the problem remains here too.
The kernel was upgraded during the update also.

# uname -a
Linux [redacted] 4.12.0-kali1-amd64 0000001 SMP Debian 4.12.6-1kali1 (2017-08-18) x86_64 GNU/Linux

# xrandr -q | grep WAYLAND
XWAYLAND0 connected 1152x864+0+0 (normal left inverted right x axis y axis) 0mm x 0mm

# dpkg -l|grep open-vm
ii open-vm-tools 2:10.1.10-1kali1 amd64 Open VMware Tools for virtual machines hosted on VMware (CLI)
ii open-vm-tools-desktop 2:10.1.10-1kali1 amd64 Open VMware Tools for virtual machines hosted on VMware (GUI)

~0007125

barry (reporter)

This is affecting me too, both on an existing VM and a new one.

How do I find the "Displays" application? The programs menu doesn't fit in the smaller screen resolution and it's hard to see anything.

~0007126

rhertzog (administrator)

FYI, I uploaded open-vm-tools_10.1.10-1kali2.dsc fixing one issue I discovered thanks to the help of Thomas Hellstrom from VMWare.

There's only one issue left. The system-wide vmtoolsd is started too early and thus the "fit guest" feature only starts working after a restart of the service:
systemctl restart open-vm-tools

~0007128

brutus (reporter)

having the same issue. have a vanilla 2017.1 vm. before update full screen resize works (as well as 'fit guest' if enabled). After apt update && apt -y full-upgrade, neither works. Logging in as Xorg and/or diabling wayland in the daemon.conf does allow both to start working, although i have then been having some odd screen glitches during resizes (might just be my system).

after the last update in this thread, went back to a vanilla snapshop, updated fully (as above) and then rebooted. issue persists, and restarting the service does not seem to affect it.

~0007129

brutus (reporter)

Want to add:
VMware Workstation Pro 12.5.7 build-5.813279
same issue when using either a debian 8 or windows 10 host
same issue if vm is created from iso or using the prebuilt vm.

I have a stack of snapshots and can go back to initial build easily.
Happy to help if I can.

~0007132

radualexandrupopescu (reporter)

@rhertzog I upgraded to lastest version and some problems got fixed but others emerged: the automatic screen resize works after restarting the service as you stated, but the screen redraw is horrible - it only redraws when it feels like it; I usually manage to trigger it with the <ENTER> key, but even so it takes seconds.
The really strange part is this behavior now affects GDM (the login screen). Anyone else having this issue?

One thing I should mention is I did a full update so I might have updated other libs like libc or kernel. If anyone can verify with a snapshot at least a day or 2 and just update open-vm{,-desktop}.

~0007134

rhertzog (administrator)

@brutus Your test dates back to 45 minutes after my message, it's not enough for the package to build get into kali-dev, then migrate to kali-rolling and then reach the mirrors. We update mirrors at most every 6h. When I mention a specific version of a package, make sure that you have (at least) that version installed. Thank you.

@radradualexandrupopescu Yes, Wayland + Linux 4.12 + VMWare is broken. I got the same issue while debugging this and notified VWWare. Apparently, this is rather VM specific, for me like you it was very visible, but for others it can show up only a slight delay while typing characters. There's no correct upstream patch yet but I'll ask them for a work-around in the mean time. If you still have the 4.11 kernel around, boot on this one (in the advanced menu in grub).

~0007136

rhertzog (administrator)

FWIW the issue with graphical rendering is tracked in 0004190.

~0007138

rhertzog (administrator)

And today you get open-vm-tools 10.1.10-1kali3 which completely fixes this issue. I'm closing the ticket.
+Notes

-Issue History
Date Modified Username Field Change
2017-08-18 09:34 zoneranger New Issue
2017-08-18 12:05 kl Note Added: 0007010
2017-08-18 12:49 zoneranger Note Added: 0007011
2017-08-18 12:50 kl Note Added: 0007012
2017-08-18 13:03 zoneranger Note Added: 0007013
2017-08-18 13:05 kl Note Added: 0007014
2017-08-18 15:18 rhertzog Note Added: 0007019
2017-08-18 16:09 zoneranger Note Added: 0007021
2017-08-18 16:12 zoneranger File Added: 1.png
2017-08-18 16:12 zoneranger Note Added: 0007022
2017-08-18 17:20 cnn Note Added: 0007024
2017-08-18 18:28 rhertzog Assigned To => rhertzog
2017-08-18 18:28 rhertzog Status new => assigned
2017-08-18 20:24 radualexandrupopescu Note Added: 0007026
2017-08-18 21:45 kl Note Added: 0007029
2017-08-19 14:14 rhertzog Note Added: 0007038
2017-08-19 14:17 rhertzog Note Added: 0007039
2017-08-19 14:24 rhertzog Note Added: 0007041
2017-08-19 21:03 radualexandrupopescu Note Added: 0007046
2017-08-19 21:26 radualexandrupopescu Note Added: 0007049
2017-08-20 10:21 rhertzog Relationship added has duplicate 0004163
2017-08-21 14:46 rhertzog Note Added: 0007056
2017-08-21 16:22 rhertzog Relationship added has duplicate 0004162
2017-08-21 20:21 radualexandrupopescu Note Added: 0007061
2017-08-21 20:27 radualexandrupopescu Note Added: 0007062
2017-08-22 09:02 rhertzog Note Added: 0007069
2017-08-22 16:16 radualexandrupopescu Note Added: 0007077
2017-08-22 19:30 rhertzog Note Added: 0007081
2017-08-23 20:05 radualexandrupopescu Note Added: 0007090
2017-08-24 08:55 rhertzog Note Added: 0007099
2017-08-24 09:47 rhertzog Note Added: 0007100
2017-08-24 12:44 cnn Note Added: 0007105
2017-08-24 15:59 rhertzog Relationship added has duplicate 0004184
2017-08-24 18:36 barry Note Added: 0007125
2017-08-24 19:52 rhertzog Note Added: 0007126
2017-08-24 20:34 brutus Note Added: 0007128
2017-08-24 21:12 brutus Note Added: 0007129
2017-08-25 01:01 radualexandrupopescu Note Added: 0007132
2017-08-25 07:08 rhertzog Note Added: 0007134
2017-08-25 07:16 rhertzog Note Added: 0007136
2017-08-25 11:49 rhertzog Status assigned => resolved
2017-08-25 11:49 rhertzog Resolution open => fixed
2017-08-25 11:49 rhertzog Fixed in Version => 2017.2
2017-08-25 11:49 rhertzog Note Added: 0007138
+Issue History