View Issue Details

IDProjectCategoryView StatusLast Update
0004163Kali Linux[All Projects] Kali Package Bugpublic2017-08-20 10:21
Reportersn0wfa11 Assigned Torhertzog  
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version2017.1 
Target VersionFixed in Version 
Summary0004163: open-vm-tools no longer works after update to 2:10.1.10-1
DescriptionJust performed an update and vm-ware-tools-desktop went to version 2:10.1.10-1 and no longer works for VMware Workstation version 12.5.7 build-5813297, most recent version. I cannot fit guest or go full-screen anymore. Copy and paste from/to the host no longer works either. During the install of the update, errors were thrown. See below. Uninstall throws the same errors. Have not been able to roll back the package either. This is impacting all of my Kali VM's that were updated.
Steps To Reproduceapt-get update -y && apt-get upgrade -y && apt-get dist-upgrade -y
Additional InformationSetting up open-vm-tools-desktop (2:10.1.10-1) ...
Failed to preset unit: Unit file run-vmblockx2dfuse.mount does not exist.
/usr/bin/deb-systemd-helper: error: systemctl preset failed on run-vmblockx2dfuse.mount: No such file or directory
Failed to get unit file state for run-vmblockx2dfuse.mount: No such file or directory

Relationships

duplicate of 0004159 resolvedrhertzog Screen resizing no longer works after recent package upgrade 

Activities

radualexandrupopescu

2017-08-19 21:24

reporter   ~0007048

@sn0wfa11 at least part of this bug is discussed here https://bugs.kali.org/view.php?id=4159
The screen resolution can be band-aided by telling GNOME to use Xorg instead of the default Wayland: when you log in, after selecting the user (and before inputting the password) you should find a "cog" button near the "Sign in" button; when you click it, a menu appears - choose "GNOME on Xorg"; continue login procedure. If you want to make it "permanent" you can add/set WaylandEnable=false under [daemon] section of /etc/gdm3/daemon.conf as per @cnn comment in the linked bug above (sorry I don't know how to link to bug id or comment it).

I will mention this bug in the other one.

sn0wfa11

2017-08-19 21:52

reporter   ~0007050

I spoke too soon on the cut and paste. After another reboot, it started working along with drag and drop. So this appears to just be a video issue. I can close this one if it is a duplicate. Let me know

sn0wfa11

2017-08-19 21:53

reporter   ~0007051

@radualexandrupopescu thanks for the info! That at least makes the ones I didn't have snapshots on usable again.

rhertzog

2017-08-20 10:21

administrator   ~0007052

Closing as duplicate of 0004159.

Issue History

Date Modified Username Field Change
2017-08-19 18:18 sn0wfa11 New Issue
2017-08-19 21:24 radualexandrupopescu Note Added: 0007048
2017-08-19 21:52 sn0wfa11 Note Added: 0007050
2017-08-19 21:53 sn0wfa11 Note Added: 0007051
2017-08-20 10:21 rhertzog Assigned To => rhertzog
2017-08-20 10:21 rhertzog Status new => closed
2017-08-20 10:21 rhertzog Resolution open => duplicate
2017-08-20 10:21 rhertzog Note Added: 0007052
2017-08-20 10:21 rhertzog Relationship added duplicate of 0004159