View Issue Details

IDProjectCategoryView StatusLast Update
0004221Kali Linux[All Projects] General Bugpublic2018-10-29 15:11
ReporterSjoerderAssigned Torhertzog 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Versionkali-dev 
Target Version2017.2Fixed in Version2017.2 
Summary0004221: Bare desktop without menu after installing kali-lxde
DescriptionI installed kali LXDE. After logging in, I get a bare desktop without any menu. This makes it pretty hard to start other programs.

I tried both kali-weekly W35 and kali-daily of today. I installed it on a VM using VMware.
Steps To Reproduce1. Install kali-lxde from ISO.
2. Log in to the new installation.

Expected: lxpanel to be running and a menu at the bottom of the screen.
Actual: bare desktop.
Additional Information# ps aux | grep lx
root 670 1.0 0.6 415900 24188 ? Ssl 14:27 0:00 lxqt-session
root 728 0.2 0.5 413452 23260 ? Sl 14:27 0:00 lxqt-notificat
root 729 0.2 0.6 586536 25148 ? Sl 14:27 0:00 lxqt-policykit
root 827 2.3 0.5 306832 21476 pts/0 Ssl+ 14:28 0:00 lxterminal
root 839 0.0 0.0 12860 1012 pts/1 S+ 14:28 0:00 grep lx

A workaround to start anything on your empty desktop:
1. Right click the desktop.
2. Create New -> Blank File.
3. Right click the new file.
4. Open with... Gvim
5. Type ":!lxterminal" to start lxterminal.

Then, you can create an ".xsession" file in your homedir with the commands to start after login, such as "lxpanel".

Relationships

has duplicate 0004134 closedrhertzog kali lxde W32 amd64 no taskbar, no desktop icons, no menus 

Activities

Sjoerder

2017-09-04 13:05

reporter   ~0007241

The desktop shown is facilitated by pcmanfm-qt. If I kill pcmanfm-qt, the desktop background changes and now you can start programs by right-clicking the desktop.

broomdodger

2017-09-04 14:11

reporter   ~0007242

I reported the same on 2017-08-06
0004134: kali lxde W32 amd64 no taskbar, no desktop icons, no menus

dookie

2017-09-04 14:26

administrator   ~0007243

Confirmed the behaviour in the newest weekly (W36) and killing pcmanfm-qt does bring the desktop back to life.

In addition, it seems the locale is set to Afar - Djibouti by default.

rhertzog

2017-09-08 14:05

administrator   ~0007269

So the problem boils down to the fact that pcmanfm (part of LXDE) incorrectly pulls in parts of LXQt and we get a mix of both at the end... and it's not working well.

I filed this on the Debian side: https://bugs.debian.org/874657 and in the mean time I uploaded a new kali-desktop-lxde (2017.2.1) which pull lxpolkit first so that the pcmanfm dependency on polkit-1-auth-agent is already satisfied and it doesn't pull LXQt anymore.

rhertzog

2017-09-08 14:06

administrator   ~0007270

We should be able to check on tomorrow's daily image if the problem is fixed.

broomdodger

2017-09-09 12:13

reporter   ~0007276

daily image 09-Sep-2017
kali-linux-lxde-rolling-amd64.iso

login to lxde desktop seems fixed

rhertzog

2017-09-09 20:53

administrator   ~0007278

Thanks for confirming, closing the ticket.

Issue History

Date Modified Username Field Change
2017-09-04 12:32 Sjoerder New Issue
2017-09-04 13:05 Sjoerder Note Added: 0007241
2017-09-04 14:11 broomdodger Note Added: 0007242
2017-09-04 14:26 dookie Note Added: 0007243
2017-09-04 14:54 rhertzog Assigned To => rhertzog
2017-09-04 14:54 rhertzog Status new => assigned
2017-09-05 14:08 rhertzog Target Version => 2017.2
2017-09-08 14:05 rhertzog Note Added: 0007269
2017-09-08 14:06 rhertzog Note Added: 0007270
2017-09-08 14:07 rhertzog Relationship added has duplicate 0004134
2017-09-09 12:13 broomdodger Note Added: 0007276
2017-09-09 20:53 rhertzog Status assigned => resolved
2017-09-09 20:53 rhertzog Resolution open => fixed
2017-09-09 20:53 rhertzog Fixed in Version => 2017.2
2017-09-09 20:53 rhertzog Note Added: 0007278