View Issue Details

IDProjectCategoryView StatusLast Update
0004376Kali Linux[All Projects] General Bugpublic2017-12-01 08:30
Reportertyowell1Assigned Torhertzog 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2017.2 
Target VersionFixed in Version2018.1 
Summary0004376: netboot fails when retrieving libc6-udev
DescriptionWhen trying to boot off the most recent netboot install, the install fails giving a "Loading libc6-udeb failed for unknown reasons. Aborting" message. The debug console shows retrieving libc6-udev 2.23-1 and then segfaults.

After this point, all available menu steps fail on themselves, and the debug menu reports a segmentation fault. Using a seperate ptty to get a dump fails as it won't open a new terminal (just repeats "Please Press Enter to activate this console" and reports a segfault in debug.
Steps To ReproduceStart install from netboot image.

Wait.

*error*
Additional InformationSame issue reported in 2016 here:

https://bugs.kali.org/view.php?id=3417&nbn=3

Activities

broomdodger

2017-11-30 05:29

reporter   ~0007635

I am curious...
Where did you find a 'netboot' of Kali?

Spyro

2017-11-30 11:49

reporter   ~0007636

This problem seems to be prevalent in the kali daily rolling located at : https://archive.kali.org/kali-daily-images/

Prior to this note

Capture.PNG (52,988 bytes)
Capture.PNG (52,988 bytes)

Spyro

2017-11-30 11:51

reporter   ~0007637

@broomdodger
I think it's the Kali light one I'm not sure though

rhertzog

2017-11-30 13:25

administrator   ~0007638

@tyowell1 Can you point us to the netboot image that you used? Where and when did you download it? Do you have a version for it?

It's very unlikely that the debug console shows a message about libc6-udeb 2.23-1 since the current version is 2.25-1...

tyowell1

2017-11-30 14:00

reporter   ~0007643

@rhertzog I am using the most recent Kali live build pulled down from git.

I will upload screenshot of failure, it is the same error Spyro uploaded a screenshot of.

Once that error appears it does not allow you to get to any options on the menu, including to get the debug logs.

llight

2017-11-30 14:24

reporter   ~0007644

Also having this issue - Followed instructions on https://www.offensive-security.com/kali-linux/kali-rolling-iso-of-doom/.

While using the resulting ISO to install, I get the error. I've attached a screenshot of the console.

kali-error-console.PNG (54,235 bytes)
kali-error-console.PNG (54,235 bytes)

llight

2017-11-30 14:25

reporter  

kali-error-console-2.PNG (54,235 bytes)
kali-error-console-2.PNG (54,235 bytes)

llight

2017-11-30 14:25

reporter  

kali-error.PNG (9,715 bytes)
kali-error.PNG (9,715 bytes)

rhertzog

2017-12-01 08:30

administrator   ~0007649

We built new installer images yesterday (version 20171009+b1). It should be fixed now.

Issue History

Date Modified Username Field Change
2017-11-29 22:42 tyowell1 New Issue
2017-11-30 05:29 broomdodger Note Added: 0007635
2017-11-30 11:49 Spyro File Added: Capture.PNG
2017-11-30 11:49 Spyro Note Added: 0007636
2017-11-30 11:51 Spyro Note Added: 0007637
2017-11-30 13:25 rhertzog Note Added: 0007638
2017-11-30 14:00 tyowell1 File Added: Screen Shot 2017-11-30 at 7.59.28 AM.png
2017-11-30 14:00 tyowell1 Note Added: 0007643
2017-11-30 14:24 llight File Added: kali-error-console.PNG
2017-11-30 14:24 llight Note Added: 0007644
2017-11-30 14:25 llight File Added: kali-error-console-2.PNG
2017-11-30 14:25 llight File Added: kali-error.PNG
2017-12-01 08:30 rhertzog Assigned To => rhertzog
2017-12-01 08:30 rhertzog Status new => closed
2017-12-01 08:30 rhertzog Resolution open => fixed
2017-12-01 08:30 rhertzog Fixed in Version => 2018.1
2017-12-01 08:30 rhertzog Note Added: 0007649