2018-04-24 12:30 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004462Kali Linux[All Projects] Kali Package Bugpublic2018-01-11 08:53
ReporterQuanticz 
Assigned Torhertzog 
PriorityhighSeveritymajorReproducibilityhave not tried
StatusclosedResolutionwon't fix 
Product Version2017.3 
Target VersionFixed in Version 
Summary0004462: apt-get upgrade not working + breaks install due to dpkg.
DescriptionToday, I tried installing Steam as root so i installed a few things, but now i can't start steam and/or even upgrade the system. I can't use install and upgrade commands, i tried using lynis to scan the computer for errors but it didn't find anything of importance or related to this error... first i downloaded Steam from official website and then used the following commands:

[+] dpkg -i steam_latest.deb
[+] apt-get install gdebi
[+] dpkg --add-architecture i386
[+] apt-get update
[+] gdebi install steam*
[+] apt-get install libgl1-mesa-dri:i386
[+] apt-get install libGL.so.1
[+] apt-get install libgl1-mesa-glx:i386
[+] apt-get install '^libc6.*'

root@kali:~# apt-get update && apt-get upgrade

Hit:1 http://downloads.metasploit.com/data/releases/metasploit-framework/apt lucid InRelease
Hit:2 http://mirrors.dotsrc.org/kali kali-rolling InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gcc-7-multilib : Depends: libc6-dev-i386 (>= 2.11) but it is not installed
 libc6-dev-x32 : Depends: libc6-dev-i386 (= 2.25-5) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

root@kali:~# apt --fix-broken install

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libc6-dev-i386
The following NEW packages will be installed:
  libc6-dev-i386
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/1,702 kB of archives.
After this operation, 9,422 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
dpkg: warning: files list file for package 'steam-launcher' missing; assuming package has no files currently installed
(Reading database ... 426492 files and directories currently installed.)
Preparing to unpack .../libc6-dev-i386_2.25-5_amd64.deb ...
Unpacking libc6-dev-i386 (2.25-5) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-dev-i386_2.25-5_amd64.deb (--unpack):
 trying to overwrite '/usr/include/bits', which is also in package libc6-dev-amd64:i386 2.25-5
Errors were encountered while processing:
 /var/cache/apt/archives/libc6-dev-i386_2.25-5_amd64.deb
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)



root@kali:~# dpkg -D3 -i /var/cache/apt/archives/libc6-dev-i386_2.25-5_amd64.deb

D000001: ensure_diversions: new, (re)loading
D000001: ensure_statoverrides: new, (re)loading
(Reading database ... 426515 files and directories currently installed.)
Preparing to unpack .../libc6-dev-i386_2.25-5_amd64.deb ...
D000001: process_archive oldversionstatus=not installed
D000002: maintscript_new nonexistent preinst '/var/lib/dpkg/tmp.ci/preinst'
Unpacking libc6-dev-i386 (2.25-5) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-dev-i386_2.25-5_amd64.deb (--install):
 trying to overwrite '/usr/include/bits', which is also in package libc6-dev-amd64:i386 2.25-5
D000002: maintscript_new nonexistent postrm '/var/lib/dpkg/tmp.ci/postrm'
Errors were encountered while processing:
 /var/cache/apt/archives/libc6-dev-i386_2.25-5_amd64.deb
Attached Files

-Relationships
+Relationships

-Notes

~0007780

crash (reporter)

Hi Quanticz,
So basically it´s breaking because you are adding a lot of external repositories and installing stuff out of the kali official repo.

Please refer to the following documentation:

Adding additional values added will most likely BREAK YOUR INSTALL (eg ppas/debian/ubuntu),
Official & default values -> http://docs.kali.org/general-use/kali-linux-sources-list-repositories
More info: https://forums.kali.org/showthread.php?27108

I will ask to close the bug as actually, it's not a kali bug.
Thank you.

~0007785

Quanticz (reporter)

Hi,

My repositories sources.list file isn't causing this error.

In /etc/apt/sources.list i have only added the following:

deb http://http.kali.org/kali kali-rolling main contrib non-free
deb-src http://http.kali.org/kali kali-rolling main contrib non-free

I have tested running " apt update && apt upgrade " but it breaks because of unmet dependencies and tells me to run " apt --fix-broken install " but now the command doesn't actually fix the broken install, i have also completely removed Steam-Launcher from the system using the search bar in root directory because this error didn't exist before i installed it so maby removing it would help but no it didn't and right after i run the " apt --fix-broken install " commands it shows this:


dpkg: warning: files list file for package 'steam-launcher' missing; assuming package has no files currently installed
(Reading database ... 426492 files and directories currently installed.)
Preparing to unpack .../libc6-dev-i386_2.25-5_amd64.deb ...
Unpacking libc6-dev-i386 (2.25-5) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-dev-i386_2.25-5_amd64.deb (--unpack):
 trying to overwrite '/usr/include/bits', which is also in package libc6-dev-amd64:i386 2.25-5
Errors were encountered while processing:
 /var/cache/apt/archives/libc6-dev-i386_2.25-5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

~0007788

rhertzog (administrator)

The problem is your "apt-get install '^libc6.*'". Why would you want to install all packages whose names are starting with libc6 ?

libc6-dev-amd64 and libc6-dev-i386 are not co-installable due to a file conflict that dpkg is reporting to you... so please just remove those package, you should not need them when you use multi-arch (which you do since you have called dpkg --add-architecture).

Anyway, it's not really a bug (except possibly the missing conflict between libc6-dev-amd64 and libc6-dev-i386) but a mistake on your side. So I'm closing the ticket.

~0007789

rhertzog (administrator)

BTW, a better way to handle the installation of third-party i386 .deb on an amd64 system would be to do this:

# dpkg --add-architecture i386
# apt update
# apt install steam_latest.deb

~0007790

rhertzog (administrator)

And the file conflict has already been reported to Debian too:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=820826

But it looks like it can't be fixed due limitations of APT's multi-arch support.
+Notes

-Issue History
Date Modified Username Field Change
2018-01-09 16:43 Quanticz New Issue
2018-01-09 17:52 crash Note Added: 0007780
2018-01-10 14:06 Quanticz Note Added: 0007785
2018-01-11 08:34 rhertzog Assigned To => rhertzog
2018-01-11 08:34 rhertzog Status new => closed
2018-01-11 08:34 rhertzog Resolution open => won't fix
2018-01-11 08:34 rhertzog Note Added: 0007788
2018-01-11 08:37 rhertzog Note Added: 0007789
2018-01-11 08:53 rhertzog Note Added: 0007790
+Issue History