View Issue Details

IDProjectCategoryView StatusLast Update
0004918Kali Linux[All Projects] Tool Upgradepublic2018-08-23 06:30
ReportercrashAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2018.2 
Target VersionFixed in Version2018.4 
Summary0004918: Update Patator from version 0.6 to 0.7
DescriptionUpdate Patator from version 0.6 to 0.7

https://github.com/lanjelot/patator

Activities

g0tmi1k

2018-08-21 13:06

administrator   ~0009488

This needs to come from Debian Security Tools Packaging Team, rather than Kali

rhertzog

2018-08-21 13:59

administrator   ~0009489

The new version is already in Debian unstable:
https://tracker.debian.org/pkg/patator

But it doesn't migrate to testing. I will cherry-pick it in the mean time.

rhertzog

2018-08-21 15:12

administrator   ~0009491

Re-opening as it's not so easy. The package doesn't migrate to kali-rolling, it likely doesn't install in arm64 due to a problematic dependency. This needs to be fixed first.

At the same time we could look whether the package can work with freerdp2-dev instead of freerdp-dev. Because that's the dependency preventing the package to migrate to testing.

sbrun

2018-08-23 06:30

manager   ~0009496

new version 0.7-2 is now in kali-rolling

Issue History

Date Modified Username Field Change
2018-08-20 09:32 crash New Issue
2018-08-20 09:32 crash Status new => assigned
2018-08-20 09:32 crash Assigned To => sbrun
2018-08-21 13:06 g0tmi1k Note Added: 0009488
2018-08-21 13:59 rhertzog Assigned To sbrun => rhertzog
2018-08-21 13:59 rhertzog Status assigned => resolved
2018-08-21 13:59 rhertzog Resolution open => fixed
2018-08-21 13:59 rhertzog Note Added: 0009489
2018-08-21 15:12 rhertzog Assigned To rhertzog => sbrun
2018-08-21 15:12 rhertzog Status resolved => confirmed
2018-08-21 15:12 rhertzog Note Added: 0009491
2018-08-23 06:30 sbrun Status confirmed => resolved
2018-08-23 06:30 sbrun Fixed in Version => 2018.4
2018-08-23 06:30 sbrun Note Added: 0009496