View Issue Details

IDProjectCategoryView StatusLast Update
0004994Kali Linux[All Projects] General Bugpublic2018-11-23 10:22
Reporterg0tmi1kAssigned Torhertzog 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2019.1 
Summary0004994: Gnome may require entropy (Slow login)
DescriptionThere has been talk (both internal & external) of Kali being ‘slow’ when logging in. (when using GNOME)

```VM feels slow at some points and it takes some time to enter after the credentials.```

@maiki believes the issue relates to not having enough random data. So installing `haveged` should fix the issue.

```It turns out that the VM needs some entropy to start so you can either click like a crazy (or press the keyboard like :cat_typing: ) or install that package.```

Activities

rhertzog

rhertzog

2018-09-17 09:29

administrator   ~0009736

Installing haveged is really trivial, the only question is where to put that dependency. Are all the problematic VM built with debian-installer from the live image?

Is this issue specific to images with a desktop or does it apply to other kind of images too?

In the former case, we might want to add the dependency to kali-desktop-common". In the latter case, maybe "kali-linux" is better suited.
broomdodger

broomdodger

2018-09-20 05:31

reporter   ~0009751

Is this a similar problem with kali light 64?

After entering username and password for login
it can take up to 5.5 minutes (timeout?) to show the desktop.

This has been happening some time after W12.
It happens on all my laptops, Toshiba, Dell, HP...

BUT...
If I jiggle the mouse it will go to desktop quickly.

I tried installing 'haveged' it had no effect.
atdtphreaker

atdtphreaker

2018-09-20 06:34

reporter   ~0009752

I experience a SLOW login too, have for a while... BUT not anything close to 5.5 minutes, more around 35-60 seconds. I just never found it to be TOO extreme to mention.


Thanks.
lwczzhiwu

lwczzhiwu

2018-09-20 14:35

reporter   ~0009754

It's happend to me too, since I updated my kernel to 4.17, It's very slow to login, but when I changed kernel version to 4.16, there was no such problem.
rhertzog

rhertzog

2018-11-23 10:22

administrator   ~0009972

I uploaded a new version of kali-meta (2019.1.1) that adds haveged as a dependency to kali-desktop-common and to kali-linux. This should fix any issue related to entropy on official images that we build.

Issue History

Date Modified Username Field Change
2018-09-17 09:22 g0tmi1k New Issue
2018-09-17 09:29 rhertzog Note Added: 0009736
2018-09-17 09:29 rhertzog Assigned To => rhertzog
2018-09-17 09:29 rhertzog Status new => assigned
2018-09-17 12:32 g0tmi1k Summary Open-VM-Tools may require entropy (Slow login) => Gnome may require entropy (Slow login)
2018-09-20 05:31 broomdodger Note Added: 0009751
2018-09-20 06:34 atdtphreaker Note Added: 0009752
2018-09-20 14:35 lwczzhiwu Note Added: 0009754
2018-11-23 10:22 rhertzog Status assigned => resolved
2018-11-23 10:22 rhertzog Resolution open => fixed
2018-11-23 10:22 rhertzog Fixed in Version => 2019.1
2018-11-23 10:22 rhertzog Note Added: 0009972