View Issue Details

IDProjectCategoryView StatusLast Update
0005427Kali Linux[All Projects] General Bugpublic2019-05-13 08:59
ReporterbroomdodgerAssigned Torhertzog 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionkali-dev 
Target VersionFixed in Version2019.2 
Summary0005427: kali -light and -xfce 2019 w08-w19 live boot takes 6 minutes
DescriptionSince 2019 w08 kali -light and -xfce live boot takes 6 minutes
Seems to work ok after boot.
Tried 4 laptops and 1 desktop, all stall.

Selecting text Install is fast, it does not stall.
After Install on HD kali works.

See attached image as to where the stall occurs.
Stall occurs at same place every time.
ONLY the xfce based DEs stall on live boot.

These kali DE live boot without stalling:
kali-linux-2019-W12-amd64.iso
kali-linux-lxde-2019-W12-amd64.iso
kali-linux-mate-2019-W12-amd64.iso

kali-linux-light-2019-W06-amd64.iso
kali-linux-light-2019.1-amd64.iso
kali-linux-light-2019.1a-amd64.iso

Steps To Reproducedownload any kali weekly w08-w19 light or xfce
burn to usb
try to live boot

Relationships

has duplicate 0005303 closedrhertzog kali linux light 2019 W07-W11 stall during usb boot 

Activities

broomdodger

2019-05-05 21:26

reporter  

kali-light-stall.jpg (739,719 bytes)

rhertzog

2019-05-06 14:28

administrator   ~0010567

The problem is that the "sudo" calls made by live-config (such as those made in the components/1170-xfce4-panel config script) are taking 3 minutes each to run. With "strace sudo", we managed to figure out that sudo is making some sort of dbus call and that it doesn't get any reply (it's sort of expected as dbus is not yet running). The dbus call is triggered by the systemd NSS module (libnss-systemd.so).

So a work around is to remove (temporarily) "systemd" from /etc/nssswitch.conf... but really it's libnss-systemd that should behave better during boot.

rhertzog

2019-05-06 15:10

administrator   ~0010568

I filed this for systemd developers: https://github.com/systemd/systemd/issues/12492

rhertzog

2019-05-07 16:03

administrator   ~0010569

In the mean time, I'm trying to work around the issue in live-config 5.20190507~kali1 by disabling the systemd NSS module.

rhertzog

2019-05-08 08:26

administrator   ~0010570

I confirm that the work-around works. systemd upstream seems to have acknowledged the problem, so hopefully it will be properly fixed at some point.

Issue History

Date Modified Username Field Change
2019-05-05 21:26 broomdodger New Issue
2019-05-05 21:26 broomdodger File Added: kali-light-stall.jpg
2019-05-06 11:43 sbrun Assigned To => sbrun
2019-05-06 11:43 sbrun Status new => assigned
2019-05-06 14:28 rhertzog Note Added: 0010567
2019-05-06 15:10 rhertzog Note Added: 0010568
2019-05-07 16:03 rhertzog Note Added: 0010569
2019-05-08 08:26 rhertzog Assigned To sbrun => rhertzog
2019-05-08 08:26 rhertzog Status assigned => resolved
2019-05-08 08:26 rhertzog Resolution open => fixed
2019-05-08 08:26 rhertzog Fixed in Version => 2019.2
2019-05-08 08:26 rhertzog Note Added: 0010570
2019-05-13 08:59 rhertzog Relationship added has duplicate 0005303