View Issue Details

IDProjectCategoryView StatusLast Update
0005619Kali Linux[All Projects] Kali Package Bugpublic2019-08-15 13:43
ReportermatthewsAssigned Torhertzog 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version2019.2 
Target VersionFixed in Version 
Summary0005619: Cannot Update or Upgrade Kali Linux
Descriptionwhen use apt dist-upgarde

Err:33 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main amd64 python-adns amd64 1.2.1-5+b3
  Connection failed [IP: 140.138.144.169 80]
Get:34 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main amd64 python-soupsieve all 1.9.2+dfsg-2 [33.5 kB]
Get:35 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main amd64 python-bs4 all 4.8.0-1 [97.1 kB]
Get:36 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main amd64 python-ubjson amd64 0.14.0-1+b1 [32.7 kB]
Get:37 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main amd64 python3-boltons all 19.1.0-2 [137 kB]
Err:38 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main amd64 python3-soupsieve all 1.9.2+dfsg-2
  Connection failed [IP: 140.138.144.169 80]
Get:39 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main amd64 python3-bs4 all 4.8.0-1 [97.0 kB]
Get:40 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main amd64 python3-jupyter-core all 4.5.0-2 [39.6 kB]
Get:41 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main amd64 ruby-nokogiri amd64 1.10.3+dfsg1-2 [114 kB]
Get:42 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main amd64 liburcu6 amd64 0.11.1-2 [70.3 kB]
Fetched 14.5 MB in 7min 6s (34.0 kB/s)
E: Failed to fetch http://http.kali.org/kali/pool/main/n/ncurses/libtinfo6_6.1+20190713-1_amd64.deb Connection failed [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/c/cutycapt/cutycapt_0.0~svn10-0.1+b1_amd64.deb Connection failed [IP: 192.99.200.113 80]
E: Failed to fetch http://ftp.yzu.edu.tw/Linux/kali/pool/main/g/ghostscript/libgs9_9.27~dfsg-3_amd64.deb Connection failed [IP: 140.138.144.169 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/g/gtk+3.0/gtk-update-icon-cache_3.24.10-1_amd64.deb Connection failed [IP: 192.99.200.113 80]
E: Failed to fetch http://ftp.yzu.edu.tw/Linux/kali/pool/main/p/python-adns/python-adns_1.2.1-5+b3_amd64.deb Connection failed [IP: 140.138.144.169 80]
E: Failed to fetch http://ftp.yzu.edu.tw/Linux/kali/pool/main/s/soupsieve/python3-soupsieve_1.9.2+dfsg-2_all.deb Connection failed [IP: 140.138.144.169 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Activities

matthews

2019-08-07 06:31

reporter  

Screenshot from 2019-08-07 13-13-33.png (483,047 bytes)

crash

2019-08-07 12:53

reporter   ~0010816

Check if you can access the address directly from Browser, please.

As it is a Public FTP service some network protection tools may block it.

matthews

2019-08-07 17:06

reporter   ~0010820

yes i can access for browser but i cant access form apt dist-upgrade



302 upgraded, 17 newly installed, 0 to remove and 0 not upgraded.
Need to get 433 kB/462 MB of archives.
After this operation, 168 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Err:1 http://http.kali.org/kali kali-rolling/main amd64 libtinfo6 amd64 6.1+20190713-1
  Connection failed [IP: 192.99.200.113 80]
Err:3 http://http.kali.org/kali kali-rolling/main amd64 gtk-update-icon-cache amd64 3.24.10-1
  Connection failed [IP: 192.99.200.113 80]
Err:2 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main amd64 cutycapt amd64 0.0~svn10-0.1+b1
  Connection failed [IP: 140.138.144.169 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/n/ncurses/libtinfo6_6.1+20190713-1_amd64.deb Connection failed [IP: 192.99.200.113 80]
E: Failed to fetch http://ftp.yzu.edu.tw/Linux/kali/pool/main/c/cutycapt/cutycapt_0.0~svn10-0.1+b1_amd64.deb Connection failed [IP: 140.138.144.169 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/g/gtk+3.0/gtk-update-icon-cache_3.24.10-1_amd64.deb Connection failed [IP: 192.99.200.113 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Screenshot from 2019-08-08 00-05-16.png (345,240 bytes)

crash

2019-08-07 17:24

reporter   ~0010821

So, for sure, there is some problem between you and the repository. Honestly, I don't think its a Kali issue.

Try this( If it works for sure there is an issue between you and the repository):

cat << EOF > /etc/apt/sources.list
deb http://archive-2.kali.org/kali kali-rolling main non-free contrib
EOF

And

apt update && apt full-upgrade && apt autoremove

matthews

2019-08-07 17:59

reporter   ~0010822

this is mine


root@Lab:/var/www/html# cat /etc/apt/sources.list
#

# deb cdrom:[Debian GNU/Linux 2019.2 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20190508-08:43]/ kali-last-snapshot contrib main non-free

#deb cdrom:[Debian GNU/Linux 2019.2 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20190508-08:43]/ kali-last-snapshot contrib main non-free

deb http://http.kali.org/kali kali-rolling main non-free contrib
# deb-src http://http.kali.org/kali kali-rolling main non-free contrib

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

matthews

2019-08-07 18:03

reporter   ~0010823

doesnt work too


root@Lab:/var/www/html# apt update && apt full-upgrade && apt autoremove
Err:1 http://archive-2.kali.org/kali kali-rolling InRelease
  Connection failed [IP: 192.99.150.27 80]
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
W: Failed to fetch http://archive-2.kali.org/kali/dists/kali-rolling/InRelease Connection failed [IP: 192.99.150.27 80]
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

crash

2019-08-07 18:09

reporter   ~0010824

So, for sure there are some issues/blocking in your network.
This one I have sent you is the main Kali repo server.

Balling

2019-08-08 09:52

reporter   ~0010826

Can please somebody comment on my issue https://bugs.kali.org/view.php?id=5613

rhertzog

2019-08-15 13:43

administrator   ~0010876

archive-2.kali.org is definitely not the main Kali server... it was one of the kali hosted mirror but we dropped most of them since we now have a CDN-powered mirror, so it's normal that it's no longer working.

cat << EOF > /etc/apt/sources.list
deb http://kali.download/kali kali-rolling main contrib non-free
EOF

The initial error message shows connection issues to the redirector (http.kali.org) and to the target mirror (in Taiwan) so it seems that you had real connection issues... maybe they have been fixed in the mean time.

Issue History

Date Modified Username Field Change
2019-08-07 06:31 matthews New Issue
2019-08-07 06:31 matthews File Added: Screenshot from 2019-08-07 13-13-33.png
2019-08-07 12:53 crash Note Added: 0010816
2019-08-07 17:06 matthews File Added: Screenshot from 2019-08-08 00-05-16.png
2019-08-07 17:06 matthews Note Added: 0010820
2019-08-07 17:24 crash Note Added: 0010821
2019-08-07 17:59 matthews Note Added: 0010822
2019-08-07 18:03 matthews Note Added: 0010823
2019-08-07 18:09 crash Note Added: 0010824
2019-08-08 09:52 Balling Note Added: 0010826
2019-08-15 13:43 rhertzog Assigned To => rhertzog
2019-08-15 13:43 rhertzog Status new => closed
2019-08-15 13:43 rhertzog Resolution open => unable to reproduce
2019-08-15 13:43 rhertzog Note Added: 0010876