View Issue Details

IDProjectCategoryView StatusLast Update
0005736Kali Linux[All Projects] General Bugpublic2019-10-10 11:41
ReporterJokerSobAssigned Torhertzog 
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.3 
Target VersionFixed in Version 
Summary0005736: Gnome3 Files Manager Not Working
Description2 days ago after updating linux, gnome file manager does not open. When I want to open anything under the "places" option at the top (home-documents-download-desktop ...), it tries to open it with "chirp", but it can't be opened naturally.

https://i.stack.imgur.com/Ru4gk.png

I've tried everything I know, but nothing changed. Methods I have applied;

apt-get update && apt-get upgrade && apt-get full-upgrade && apt-get dist-upgrade
apt-get autoremove && apt-get autoclean && apt-get clean && apt-get autoremove --purge
apt-get --purge remove
apt-get install gnome-core kali-defaults kali-root-login desktop-base
apt-get -f install --reinstall
tracker reset -r
tracker reset -e
dpkg --configure -a
Live CD(USB) Recovery Mode
Steps To Reproduceapt-get update && apt-get upgrade && apt-get full-upgrade && apt-get dist-upgrade results:
- The current status of the following packages will be maintained:
  eog gnome-font-viewer gnome-software gnome-software-plugin-flatpak libtotem0 totem

apt-get install gnome-core kali-defaults kali-root-login desktop-base results:
- The following packages have unmet dependencies:
 gnome-core : Addictions: evince (>= 3.30) but will not be installed
                         Addictions: nautilus (>= 3.30) but will not be installed
                         Addictions: gnome-sushi (>= 3.30) but will not be installed
E: Problems could not be fixed, You have broken packages that are kept.

apt-get -f install --reinstall evince results:
- The following packages have unmet dependencies:
 evince : Addictions: libgnome-desktop-3-18 (>= 3.17.92) but not installable
E: Problems could not be fixed, You have broken packages that are kept.

apt-get -f install --reinstall nautilus results:
- The following packages have unmet dependencies:
 nautilus : Addictions: libgnome-desktop-3-18 (>= 3.17.92) but not installable
Recommended: gnome-sushi but will not be installed
E: Problems could not be fixed, You have broken packages that are kept.

apt-get -f install --reinstall gnome-sushi results:
- The following packages have unmet dependencies:
 gnome-sushi : Addictions: nautilus (>= 3.2) but not installable
E: Problems could not be fixed, You have broken packages that are kept.

apt-get -f install --reinstall eog results:
- The following packages have unmet dependencies:
 eog : Addictions: libgnome-desktop-3-18 (>= 3.17.92) but not installable
E: Problems could not be fixed, You have broken packages that are kept.

apt-get -f install --reinstall gnome-font-viewer results:
- The following packages have unmet dependencies:
 gnome-font-viewer : Addictions: libgnome-desktop-3-18 (>= 3.17.92) but not installable
E: Problems could not be fixed, You have broken packages that are kept.

apt-get -f install --reinstall gnome-software results:
- The following packages have unmet dependencies:
 gnome-software : Addictions: libgnome-desktop-3-18 (>= 3.18.0) but not installable
E: Problems could not be fixed, You have broken packages that are kept.

apt-get -f install --reinstall gnome-software-plugin-flatpak results:
- The following packages have unmet dependencies:
 gnome-software-plugin-flatpak : Addictions: gnome-software (= 3.30.6-5+b1) but 3.30.6-5 will be installed
E: Problems could not be fixed, You have broken packages that are kept.

apt-get -f install --reinstall libtotem0 results:
- The following packages have unmet dependencies:
 libtotem0 : Addictions: libgnome-desktop-3-18 (>= 3.17.92) but not installable
E: Problems could not be fixed, You have broken packages that are kept.

apt-get -f install --reinstall totem results:
- The following packages have unmet dependencies:
 totem : Addictions: libtotem0 (>= 3.34.0-1+b1) but 3.34.0-1 will be installed
Recommended: totem-plugins but will not be installed
E: Problems could not be fixed, You have broken packages that are kept.

apt-get -f install --reinstall totem-plugins results:
- The following packages have unmet dependencies:
 totem-plugins : Addictions: libtotem0 (>= 3.34.0-1+b1) but 3.34.0-1 will be installed
                            Addictions: totem (= 3.34.0-1+b1) but 3.34.0-1 will be installed
                           Addictions: gir1.2-totem-1.0 (= 3.34.0-1+b1) but not installable
E: Problems could not be fixed, You have broken packages that are kept.

apt-get -f install --reinstall gir1.2-totem results:
- The following packages have unmet dependencies:
 gir1.2-totem-1.0 : Addictions: libtotem0 (>= 3.34.0-1+b1) but 3.34.0-1 will be installed
E: Problems could not be fixed, You have broken packages that are kept.
Additional Information- it works fine when I make a file open selection with any application. (etc: text editor)

- dconf-editor I set the settings by default with dconf-editor

Activities

JokerSob

2019-10-09 23:27

reporter  

2019-10-09_04-08.png (3,747 bytes)
2019-10-09_04-08.png (3,747 bytes)
2019-10-10_02-26.png (66,156 bytes)
2019-10-10_02-26.png (66,156 bytes)

dactyl

2019-10-10 09:32

reporter   ~0011181

Hi Joker, just got the same problem here...
the package 'libgnome-desktop-3-18' seems to be missing from kali default repo, only 'libgnome-desktop-3-17' is present.
My workaround:
1 - manually install the package or add the Debian Sid repo to apt source: deb http://deb.debian.org/debian sid main non-free contrib
2 - run apt update BUT ONLY install this missing package 'libgnome-desktop-3-18'
3 - comment the Deb sid entry on apt sources and run apt update again
4 - from now on you should be able to install all missing packages
5 - finally install nautilus

rhertzog

2019-10-10 11:41

administrator   ~0011183

We completed the transition to Gnome 3.34. Should be fixed in kali-rolling now.

Issue History

Date Modified Username Field Change
2019-10-09 23:27 JokerSob New Issue
2019-10-09 23:27 JokerSob File Added: 2019-10-09_04-08.png
2019-10-09 23:27 JokerSob File Added: 2019-10-10_02-26.png
2019-10-10 09:32 dactyl Note Added: 0011181
2019-10-10 11:41 rhertzog Assigned To => rhertzog
2019-10-10 11:41 rhertzog Status new => resolved
2019-10-10 11:41 rhertzog Resolution open => fixed
2019-10-10 11:41 rhertzog Note Added: 0011183