View Issue Details

IDProjectCategoryView StatusLast Update
0005885Kali Linux[All Projects] General Bugpublic2019-12-10 09:40
ReporterJokerSob Assigned Torhertzog  
PriorityimmediateSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.4 
Target VersionFixed in Version2020.1 
Summary0005885: Wifi adapter issue after update
DescriptionI did a clean installation of Kali Linux 64-Bit 2019.4. Everything was working fine on first boot. However, after running the update command, the wifi adapter (alpha - atheros AR9271) does not connect to the internet and fails.

apt update && apt upgrade && apt-get update && apt-get upgrade && apt dist-upgrade && apt full-upgrade && apt-get dist-upgrade && apt-get full-upgrade
Steps To Reproduce1) Kali Linux 64-Bit 2019.4 Clean installation

2) apt update && apt upgrade && apt-get update && apt-get upgrade && apt dist-upgrade && apt full-upgrade && apt-get dist-upgrade && apt-get full-upgrade

3) wifi adapter (alpha - atheros AR9271) does not connect to the internet and fails.
Additional Information Everything was working fine on first boot. The problem occurred after the first update.

Activities

JokerSob

2019-12-07 15:56

reporter  

usama

2019-12-08 03:56

reporter   ~0011598

same here with my railink rt3070l adapter but i renamed it back to wlan1 using "ip link set wlx000762cfe name wlan1"

usama

2019-12-08 03:57

reporter   ~0011599

This problem first appeared after upgrading to kali 2019.4.

JokerSob

2019-12-08 20:28

reporter   ~0011603

I did a clean installation again and did not run the update - upgrade command. I'm thinking of not updating - upgrading until the problem is corrected.

elwood

2019-12-08 22:18

administrator   ~0011604

Yes, it looks like something may have snuck in Friday from upstream. Please don't update until we have a chance to isolate and correct. Thanks for the report.

a6390805

2019-12-09 12:07

reporter   ~0011606

Edit file
73-special-net-names.rules
with your favorite editor
in /etc/udev/rules.d/

copy/paste in this information. remember, each rule needs to be on it's own line and reboot...


# wlan0
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",
ATTR{address}=="00:01:02:03:04:05",
ATTR{dev_id}=="0x0", ATTR{type}=="1",
KERNEL=="wlan*", NAME="wlan0"

rhertzog

2019-12-10 09:40

administrator   ~0011624

This should be fixed with kali-defaults 2020.1.0.

To disable the MAC-based naming, kali-defaults is now setting up this symlink:
ln -sf /dev/null /etc/systemd/network/73-usb-net-by-mac.link

This regression is related to a change in systemd 244-2 that replaced the former udev rule with this systemd configuration file.

Issue History

Date Modified Username Field Change
2019-12-07 15:54 JokerSob New Issue
2019-12-07 15:56 JokerSob File Added: Ekran görüntüsü_2019-12-07_18-56-22.png
2019-12-08 03:56 usama Note Added: 0011598
2019-12-08 03:57 usama Note Added: 0011599
2019-12-08 20:28 JokerSob File Added: Ekran görüntüsü_2019-12-08_23-24-12.png
2019-12-08 20:28 JokerSob Note Added: 0011603
2019-12-08 22:18 elwood Assigned To => rhertzog
2019-12-08 22:18 elwood Status new => assigned
2019-12-08 22:18 elwood Note Added: 0011604
2019-12-09 12:07 a6390805 Note Added: 0011606
2019-12-10 09:40 rhertzog Status assigned => resolved
2019-12-10 09:40 rhertzog Resolution open => fixed
2019-12-10 09:40 rhertzog Fixed in Version => 2020.1
2019-12-10 09:40 rhertzog Note Added: 0011624