View Issue Details

IDProjectCategoryView StatusLast Update
0006351Kali Linux[All Projects] General Bugpublic2020-12-01 10:50
ReporterTriomph Assigned To 
Status newResolutionopen 
Product Version2020.1 
Target VersionFixed in Version 
Summary0006351: Graphics artifacts
(I apologize for my English, it's not my native language)

I'm completely new to Unix OS.

I just installed Kali Linux with an USB drive on Rufus 3.10 (on Windows 10) and I installed it on a laptop, everything work perfectly during the installation except one time I got an error on 'Choosing and installing software' (I did it a second time and it worked fine). I have now Kali Linux and Windows 10 on the laptop (dual-boot).

But I have a big graphics problem,
There is a lot of graphics artifacts that totally prevents me from using Kali Linux (see Uploaded Files)

Important: I found two other users (on the forum) having exactly the same problem as me.
- One have an ASUS laptop, like me
- and the other one have an AMD Ryzen GPU, like me.

This bug is surely new in the 2020.1 version.

Thanks you for taking the time to read.
Good day to you.



2020-05-02 18:02


IMG_1250-min.JPG (1,473,579 bytes)
IMG_1246-min.JPG (1,181,968 bytes)


2020-05-02 22:23

reporter   ~0012723

Ah, yes...I think you're referring to me here with the ASUS laptop
While you're at it, please paste the output for the following commands:

sudo lspci -vnn | grep VGA -A 12

lsmod | grep amd

Also, what's your laptop's model?


2020-05-03 07:47

reporter   ~0012724

sudo lspci -vnn | grep VGA -A 12 :
05:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Picasso [1002:15d8] (rev c2) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Picasso [1043:1bb1]
        Flags: bus master, fast devsel, latency 0, IRQ 24
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at f0000000 (64-bit, prefetchable) [size=2M]
        I/O ports at d000 [size=256]
        Memory at f7700000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: [48] Vendor Specific Information: Len=08 <?>
        Capabilities: [50] Power Management version 3
        Capabilities: [64] Express Legacy Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable- Count=1/4 Maskable- 64bit+
        Capabilities: [c0] MSI-X: Enable+ Count=3 Masked-
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>

lsmod | grep amd :
edac_mce_amd 32768 0
kvm_amd 110592 0
ccp 102400 1 kvm_amd
kvm 798720 1 kvm_amd
amdgpu 5021696 19
gpu_sched 36864 1 amdgpu
i2c_algo_bit 16384 2 amdgpu,nouveau
ttm 122880 2 amdgpu,nouveau
drm_kms_helper 233472 2 amdgpu,nouveau
mfd_core 20480 1 amdgpu
drm 585728 10 gpu_sched,drm_kms_helper,amdgpu,ttm,nouveau

And I'm on an Asus X570ZD.


2020-05-04 11:20

reporter   ~0012725

I think Kali Linux is only using my integrated GPU (on the AMD CPU), but I've a GTX 1050 in my laptop and it doesn't appear anywhere.
Maybe someone has a tip to change the used GPU ?



2020-05-04 12:00

reporter   ~0012726

Problem is that Kali's not even detecting your NVIDIA card.

How about booting Kali live or any other distro? Do you still get the same artifacts? I get artifacts on select distros and/or display managers like XFCE.

Also, type this command and let me know if you get an empty output:
lsmod | grep nvidia


2020-05-04 12:53

reporter   ~0012727

I tried lsmod | grep nvidia
and I don't get anything.

So do I need to reinstall Kali (I took the installer 64-bit ISO, maybe I should take the Kali Live this time) ?


2020-05-04 13:11

reporter   ~0012728

You don't need to "reinstall"..Just grab the live iso, put it onto a USB flash disk using Balena Etcher, and boot into Live mode..Check if you still have the same artifacts


2020-05-04 15:23

reporter   ~0012729

I don't know why it taked so long to download, but good news it's working perfectly on the 'Live' one

Should I completly reinstall the other one ?


2020-05-04 15:28

reporter   ~0012730

What's the display manager you're using on your installed version? Gnome, XFCE, KDE, or MATE?

If you're unsure, just type the command cat /etc/X11/default-display-manager (On your installed system, not the live one)


2020-05-04 15:29

reporter   ~0012731

I took XFCE when installing


2020-05-04 15:31

reporter   ~0012732

(The output is : /usr/sbin/lightdm)


2020-05-04 15:34

reporter   ~0012733

You can try the following:
sudo apt update && sudo apt upgrade -y
sudo apt install gdm3 -y
sudo dpkg-reconfigure gdm3 (and choose gdm3 as your default display manager)


Backup any files you saved and install the latest version
Also, make sure to add another display manager like Gnome as a fallback option in case XFCE still has artifacts


2020-05-04 18:45

reporter   ~0012734

First one didn't worked.
Second one, I reinstalled everything and it was ok when I used it, but when I rebooted it, everything goes sh*t, exactly like the first time.

I don't think the problem comes from me...


2020-05-04 19:07

reporter   ~0012735

I'm assuming that's on XFCE (lightdm)? I don't know what's up with it on AMD/NVIDIA combos
If you *are* using XFCE right now, switch to gdm3 and reboot

sudo dpkg-reconfigure gdm3

Seems like ASUS with the AMD/NVIDIA combo is just asking for trouble with the drivers as far as I've experienced.
My other systems with Intel/NVIDIA rarely had any display driver problems, but I don't know. Hopefully there's gonna a fix for that.
I tried my best to help you out here with what I know. For actual fixes, I guess we'll have to wait for devs if they decide to work on this or not (bear in mind we're kind of a small subset of users with this issue)


2020-05-04 19:34

reporter   ~0012736

That annoys me...

But thank you a lot, for helping me =)

I've a little question,
I sent a JPG of a missing firmware poping during the Kali Linux boot, and I think it never appeared at the very first Kali boot,
It only appears at the second one and more, as well as with the graphic artifacts..
All of that is may due to 'admgpu/picasso_ta.bin'


2020-05-04 19:53

reporter   ~0012737

Yep...I have the same set of messages popping up every boot. I use gdm3 with (mostly) no problems anyway (up until that HDMI problem showed up with the latest update).


2020-06-03 15:11

reporter   ~0012861

Sorry to bring up the topic, but the problem persists. And for this type of bug, priority should be urgent.
(And I would like to add that the bug only appears after logging in, before I have no artifacts)

Please consider this problem.


2020-06-03 20:04

reporter   ~0012863

I think I understand because a few days ago I had this problem with my Asus AMD CPU. You can download your GPU driver (NVIDIA) and install it for Linux x86_64 and then config switchable graphics in Linux. Please send the screenshot after installing the GPU driver card.


2020-06-03 21:42

reporter   ~0012866

Do you have a simple guide to install Nvidia's drivers, because i'm struggling, it isn't user-friendly at all... (One time I need to leave the X server, the other time I need to....)


2020-06-03 21:59

reporter   ~0012867

Ok so,
I installed the driver, but Kali is still using AMD integrated graphic card.

Drivers2.png (1,724,800 bytes)


2020-06-03 22:06

reporter   ~0012868

@Triomph unfortunately, I cannot, for the life of me, remember how I installed it properly, but such a "simple guide" simply does not exist.

I can't recommend any of the forums/blogs I scoured for info either because you'll almost always bork the setup at some point or another. It's gonna take a couple of tries before finding the right sequence that works for you.

If you're up for the hunt, do your research until you find stuff that works. If you're out of time, just spin it up on a Virtual Machine on your host OS.
An alternative would be downloading another distro and manually downloading Kali packages you use frequently.

However, if you *REALLY* wanna give it a shot anyway, I think this was one of the guides that were promising. Try it at your own risk if you want:


2020-06-03 22:23

reporter   ~0012869

I think the best thing to do is, as you said, to hunt until I find a solution.
I will leave the subject open in case someone has a solution, but now I will search for a solution by myself.
(At least I would learn a lot more about Kali like that ahah)

Issue History

Date Modified Username Field Change
2020-05-02 18:02 Triomph New Issue
2020-05-02 18:02 Triomph File Added: IMG_1250-min.JPG
2020-05-02 18:02 Triomph File Added: IMG_1246-min.JPG
2020-05-02 22:23 X0RW3LL Note Added: 0012723
2020-05-03 07:47 Triomph Note Added: 0012724
2020-05-04 11:20 Triomph Note Added: 0012725
2020-05-04 12:00 X0RW3LL Note Added: 0012726
2020-05-04 12:53 Triomph Note Added: 0012727
2020-05-04 13:11 X0RW3LL Note Added: 0012728
2020-05-04 15:23 Triomph Note Added: 0012729
2020-05-04 15:28 X0RW3LL Note Added: 0012730
2020-05-04 15:29 Triomph Note Added: 0012731
2020-05-04 15:31 Triomph Note Added: 0012732
2020-05-04 15:34 X0RW3LL Note Added: 0012733
2020-05-04 18:45 Triomph Note Added: 0012734
2020-05-04 19:07 X0RW3LL Note Added: 0012735
2020-05-04 19:34 Triomph Note Added: 0012736
2020-05-04 19:53 X0RW3LL Note Added: 0012737
2020-06-03 15:11 Triomph Note Added: 0012861
2020-06-03 20:04 Alexandros_Adamos Note Added: 0012863
2020-06-03 21:42 Triomph Note Added: 0012866
2020-06-03 21:59 Triomph File Added: Drivers2.png
2020-06-03 21:59 Triomph Note Added: 0012867
2020-06-03 22:06 X0RW3LL Note Added: 0012868
2020-06-03 22:23 Triomph Note Added: 0012869
2020-12-01 10:48 g0tmi1k Priority high => normal
2020-12-01 10:50 g0tmi1k Severity major => minor