View Issue Details

IDProjectCategoryView StatusLast Update
0006659Kali Linux[All Projects] Tool Upgradepublic2020-09-02 16:17
Reporteranaphylactic_penguin Assigned To 
PriorityimmediateSeveritymajorReproducibilityhave not tried
Status assignedResolutionopen 
Product Version2020.2 
Target VersionFixed in Version 
Summary0006659: libc6:amd64 (2.31-2) WSL Kali
Descriptionapt upgrade:

Setting up libc6:amd64 (2.31-2) ...
Checking for services that may need to be restarted...
Checking init scripts...
Nothing to restart.
sleep: cannot read realtime clock: Invalid argument
dpkg: error processing package libc6:amd64 (--configure):
 installed libc6:amd64 package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 libc6:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
Additional InformationMacBook Air A1466 Bootcamp
My computer had an EFI crash a month ago. Power states are damaged but the computer is still operational. BTW anybody have similar experiences?

Relationships

has duplicate 0006699 resolvedsteev Libc6/Libc unmet dependencies bug 

Activities

steev

2020-08-16 20:28

developer   ~0013281

Are you using WSL1 or WSL2? What is the Windows 10 version (please give the exact version/build, not latest or most recent update please!)

I've not actually been able to reproduce this here, but I know it happens as it's reported multiple times with multiple distros. For me, both WSL1 and WSL2 installed 2.31-2 (and -3) without issue. I don't have a bootcamp setup though I doubt that has to do with anything.

I see 2.31-3 coming in the pipeline, perhaps that will fix the issue for you when it arrives.

anaphylactic_penguin

2020-08-17 02:33

reporter   ~0013284

winver:

Version 1903 (OS Build 18362.1016)

steev

2020-08-17 16:41

developer   ~0013285

Is there any way you could update to 2004? If Windows Update claims there is no update available, it's likely being blocked because OneDrive is installed separately, and you can uninstall OneDrive and then the update should show up as available.

I can't reproduce the sleep issue on any of my machines, but they're all on 2004+ at this point, and I would urge you to update to it as well at this point.

anaphylactic_penguin

2020-08-18 16:11

reporter   ~0013289

I updated to Version 2004 (OS Build 19041.450), still no dice.

According to the Microsoft document (https://docs.microsoft.com/en-us/windows/wsl/compare-versions), WSL is not supported at all on builds lower than 19041; however, I was able to install it on Version 1903 (OS Build 18362.1016) using the command: Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux.

Perhaps uninstalling then reinstalling WSL and Kali will work.

Donovan.Middleton

2020-08-27 04:18

reporter   ~0013330

I have the same issue with my AMD systems as well. Have tried it multiple times on two separate systems with both WSL and WSL2.

Soon as I install the app and it does the initial configuration (new user, password, confirm password), I attempt to run:
sudo apt update <-- works fine.
sudo apt upgrade <-- fails.

I attached a screenshot of the "sudo apt upgrade" run with the error after a fresh install.

Kali Linux Update Error.png (353,977 bytes)

anaphylactic_penguin

2020-08-28 06:45

reporter   ~0013337

Here's the whole story:
I left my computer by my living room window for the night. Battery was exhausted the next morning -odd because Macs have a very good sleep function. First red flag.

I booted into Ubuntu and an EFI error report was generated. Second red flag. Prior to this crash, suspend was the only state that misbehaved. Now, if the computer is powered off or suspended you have to disconnect the battery then connect it again, plug-in the power cord and press the power button to boot. Also, if you tap the power button while the computer is turned on it immediately powers off -no software dialog asking the user to power off.

Running Apple's diagnostics through the recovery software detects a System Management Controller issue (Reference Code: PFM006) & a power management system issue (Reference Code: PPN001). Third red flag. Also, now my battery is reporting a 'replace now'. BTW this all happened around the same time Apple released their update on Catalina. The major change I noticed was my new EFI version. Fourth red flag. I wish I backed-up my prior version! Needless to say, I was not anticipating this event to occur.

My best estimation is that either bloatware is making its way into EFI software or somebody thinks they are smart somewhere but in reality they are causing more problems than good. Have you ran a diagnostic on the hardware?

Issue History

Date Modified Username Field Change
2020-08-16 17:52 anaphylactic_penguin New Issue
2020-08-16 17:52 anaphylactic_penguin Status new => assigned
2020-08-16 17:52 anaphylactic_penguin Assigned To => sbrun
2020-08-16 20:28 steev Note Added: 0013281
2020-08-17 02:33 anaphylactic_penguin Note Added: 0013284
2020-08-17 16:41 steev Note Added: 0013285
2020-08-18 16:11 anaphylactic_penguin Note Added: 0013289
2020-08-26 11:40 sbrun Assigned To sbrun =>
2020-08-27 04:18 Donovan.Middleton File Added: Kali Linux Update Error.png
2020-08-27 04:18 Donovan.Middleton Note Added: 0013330
2020-08-28 06:45 anaphylactic_penguin Note Added: 0013337
2020-09-02 16:17 steev Relationship added has duplicate 0006699