View Issue Details

IDProjectCategoryView StatusLast Update
0006732Kali Linux[All Projects] New Tool Requestspublic2020-10-02 12:12
Reporternutmeg987 Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0006732: rustscan - Turns a 17 minutes Nmap scan into 19 seconds.
Descriptionrustscan wraps nmap to make it much faster to identify open ports and optionally run nmap scripts on it
already a deb but would be nicer in the repos for easier maintenance

homepage & download: https://github.com/RustScan/RustScan

Relationships

has duplicate 0006759 closed rustscan 

Activities

g0tmi1k

2020-09-25 13:05

administrator   ~0013492

Not sure exactly what this brings to the table.
There are various flag you can do with nmap to speed it up.

This looks like just a wrapper?

g0tmi1k

2020-09-25 13:05

administrator   ~0013493

https://www.reddit.com/r/netsec/comments/hw4l8r/rustscan_faster_nmap_scanning_with_rust_65k_ports/fyyotbt/

Issue History

Date Modified Username Field Change
2020-09-20 17:56 nutmeg987 New Issue
2020-09-25 13:03 g0tmi1k Summary request for rustscan => rustscan - Turns a 17 minutes Nmap scan into 19 seconds.
2020-09-25 13:05 g0tmi1k Note Added: 0013492
2020-09-25 13:05 g0tmi1k Status new => closed
2020-09-25 13:05 g0tmi1k Resolution open => won't fix
2020-09-25 13:05 g0tmi1k Note Added: 0013493
2020-10-02 12:12 g0tmi1k Relationship added has duplicate 0006759