View Issue Details

IDProjectCategoryView StatusLast Update
0007187Kali Linux[All Projects] Kali Package Bugpublic2021-05-27 06:59
Reporterc3s4r Assigned Tosbrun  
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version2021.1 
Target VersionFixed in Version 
Summary0007187: Driver for Ralink Technology, Corp. MT7601U Wireless Adapter
DescriptionYes, I've seen on many github repositories that its driver have been included into kali's main stream from/after kernel version 4.1 or 4.2

Still, my adapter doesn't seem to be recognised on my workstation (as full installation, like Real OS) but It did worked in VirtualBox (like Virtual OS)
Please fix this ASAP.

I'm using Up-To-Date kali system.

Activities

Michu

2021-05-12 15:03

reporter   ~0014543

iwconfig ifconfig give output of those commands and dmesg | grep error and journalctl -xe maybe we can figure out in there what's the problem

c3s4r

2021-05-13 10:14

reporter   ~0014546

CONCERNED DEVICE IS "wlan1"
NO NEED TO WORRY ABOUT "wrx0"(changed name) and "inet, inet6, ether, ACCESS POINT" values, I've modified them.
@Michu

┌──(c3s4r㉿kali)-[~]
└─$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11 ESSID:"KratoSkills_5GHz"
          Mode:Managed Frequency:5.26 GHz Access Point: 11:22:33:44:55:66
          Bit Rate=780 Mb/s Tx-Power=20 dBm
          Retry short limit:7 RTS thr:off Fragment thr:off
          Power Management:on
          Link Quality=61/70 Signal level=-49 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:8 Missed beacon:0

wlan1 IEEE 802.11 ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
          Retry short limit:7 RTS thr:off Fragment thr:off
          Power Management:off
          
wrx0 no wireless extensions.

┌──(c3s4r㉿kali)-[~]
└─$ ifconfig
eth0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
        ether AA:BB:CC:DD:EE:FF txqueuelen 1000 (Ethernet)
        RX packets 0 bytes 0 (0.0 B)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 0 bytes 0 (0.0 B)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
        inet 127.0.0.1 netmask 255.0.0.0
        inet6 ::1 prefixlen 128 scopeid 0x10<host>
        loop txqueuelen 1000 (Local Loopback)
        RX packets 16 bytes 880 (880.0 B)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 16 bytes 880 (880.0 B)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wrx0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST> mtu 1500
        inet 1.1.1.1 netmask 255.255.0.0 destination 1.0.0.1
        inet6 fe70::cf55:da27:56b7:44aa prefixlen 64 scopeid 0x20<link>
        unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 txqueuelen 500 (UNSPEC)
        RX packets 4965 bytes 5030768 (4.7 MiB)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 3907 bytes 900950 (879.8 KiB)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
        inet 1.1.1.1 netmask 255.255.255.0 broadcast 1.0.0.1
        inet6 fe70::cf55:da27:56b7:44aa prefixlen 64 scopeid 0x20<link>
        ether AA:BB:CC:DD:EE:FF txqueuelen 1000 (Ethernet)
        RX packets 81219 bytes 91022356 (86.8 MiB)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 37518 bytes 6297768 (6.0 MiB)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
        ether AA:BB:CC:DD:EE:FF txqueuelen 1000 (Ethernet)
        RX packets 0 bytes 0 (0.0 B)
        RX errors 0 dropped 0 overruns 0 frame 0
        TX packets 0 bytes 0 (0.0 B)
        TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

                                                                                                                                                                                              
┌──(c3s4r㉿kali)-[~]
└─$ sudo dmesg | grep error
[ 1.820893] pcieport 0000:00:1d.0: DPC: error containment capabilities: Int Msg #0, RPExt+ PoisonedTLP+ SwTrigger+ RP PIO Log 4, DL_ActiveErr+
[ 1.821388] pcieport 0000:00:1d.6: DPC: error containment capabilities: Int Msg #0, RPExt+ PoisonedTLP+ SwTrigger+ RP PIO Log 4, DL_ActiveErr+
[ 5.266483] EXT4-fs (sda4): re-mounted. Opts: errors=remount-ro
                                                                                                                                                                                              
┌──(c3s4r㉿kali)-[~]
└─$ journalctl -xe
Hint: You are currently not seeing messages from other users and the system.
      Users in groups 'adm', 'systemd-journal' can see all messages.
      Pass -q to turn off this notice.
May 13 05:55:31 kali sudo[6721]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/local/bin/protonvpn c --cc us
May 13 05:55:31 kali sudo[6721]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 05:55:43 kali dbus-daemon[1086]: [session uid=1000 pid=1086] Activating service name='org.freedesktop.secrets' requested by ':1.36' (uid=1000 pid=1286 comm="nm-applet ")
May 13 05:55:43 kali gnome-keyring-daemon[6818]: couldn't access control socket: /run/user/1000/keyring/control: No such file or directory
May 13 05:55:43 kali gnome-keyring-d[6818]: couldn't access control socket: /run/user/1000/keyring/control: No such file or directory
May 13 05:55:43 kali sudo[6721]: pam_unix(sudo:session): session closed for user root
May 13 05:55:43 kali dbus-daemon[1086]: [session uid=1000 pid=1086] Successfully activated service 'org.freedesktop.secrets'
May 13 05:55:46 kali sudo[6833]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/local/bin/protonvpn d
May 13 05:55:46 kali sudo[6833]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 05:55:47 kali sudo[6833]: pam_unix(sudo:session): session closed for user root
May 13 05:55:47 kali sudo[6848]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/sbin/ifconfig down
May 13 05:55:47 kali sudo[6848]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 05:55:47 kali sudo[6848]: pam_unix(sudo:session): session closed for user root
May 13 06:00:00 kali sudo[7411]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/bin/apt-get update
May 13 06:00:00 kali sudo[7411]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 06:00:08 kali sudo[7411]: pam_unix(sudo:session): session closed for user root
May 13 06:00:08 kali sudo[7616]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/bin/apt-get dist-upgrade -Vy
May 13 06:00:08 kali sudo[7616]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 06:00:09 kali sudo[7616]: pam_unix(sudo:session): session closed for user root
May 13 06:00:09 kali sudo[7620]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/bin/pip3 install protonvpn-cli --upgrade
May 13 06:00:09 kali sudo[7620]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 06:00:10 kali sudo[7620]: pam_unix(sudo:session): session closed for user root
May 13 06:00:10 kali sudo[7624]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/bin/apt-get autoremove -y
May 13 06:00:10 kali sudo[7624]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 06:00:10 kali sudo[7624]: pam_unix(sudo:session): session closed for user root
May 13 06:00:10 kali sudo[7628]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/bin/apt-get autoclean
May 13 06:00:10 kali sudo[7628]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 06:00:10 kali sudo[7628]: pam_unix(sudo:session): session closed for user root
May 13 06:00:10 kali sudo[7632]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/bin/apt-get clean
May 13 06:00:10 kali sudo[7632]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 06:00:10 kali sudo[7632]: pam_unix(sudo:session): session closed for user root
May 13 06:00:18 kali sudo[7650]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/sbin/ifconfig wlan0 down
May 13 06:00:18 kali sudo[7650]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 06:00:18 kali sudo[7650]: pam_unix(sudo:session): session closed for user root
May 13 06:00:18 kali sudo[7652]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/bin/macchanger -r -b wlan0
May 13 06:00:18 kali sudo[7652]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 06:00:18 kali sudo[7652]: pam_unix(sudo:session): session closed for user root
May 13 06:00:18 kali sudo[7656]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/sbin/ifconfig wlan0 up
May 13 06:00:18 kali sudo[7656]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 06:00:18 kali sudo[7656]: pam_unix(sudo:session): session closed for user root
May 13 06:00:18 kali sudo[7658]: c3s4r : TTY=pts/1 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/local/bin/protonvpn c --cc us
May 13 06:00:18 kali sudo[7658]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 06:00:31 kali sudo[7658]: pam_unix(sudo:session): session closed for user root
May 13 06:01:22 kali dbus-daemon[1086]: [session uid=1000 pid=1086] Activating service name='org.freedesktop.thumbnails.Thumbnailer1' requested by ':1.17' (uid=1000 pid=1218 comm="Thunar >
May 13 06:01:22 kali org.freedesktop.thumbnails.Thumbnailer1[8002]: Registered thumbnailer /usr/bin/gdk-pixbuf-thumbnailer -s %s %u %o
May 13 06:01:22 kali org.freedesktop.thumbnails.Thumbnailer1[8002]: Registered thumbnailer atril-thumbnailer -s %s %u %o
May 13 06:01:22 kali org.freedesktop.thumbnails.Thumbnailer1[8002]: Registered thumbnailer /usr/bin/gdk-pixbuf-thumbnailer -s %s %u %o
May 13 06:01:22 kali dbus-daemon[1086]: [session uid=1000 pid=1086] Successfully activated service 'org.freedesktop.thumbnails.Thumbnailer1'
May 13 06:03:31 kali sudo[8158]: c3s4r : TTY=pts/0 ; PWD=/home/c3s4r ; USER=root ; COMMAND=/usr/bin/dmesg
May 13 06:03:31 kali sudo[8158]: pam_unix(sudo:session): session opened for user root(uid=0) by (uid=1000)
May 13 06:03:31 kali sudo[8158]: pam_unix(sudo:session): session closed for user root

Michu

2021-05-13 11:46

reporter   ~0014547

i don't get it the output of iwconfig shows that in my opinion is ok with wireless card but is this output from your vm or real os second you don't have internet access or what because i don't understand the problem maybe im stupid but i don't see one could please explain what's the problem with the card from logs everything is fine and last one you have wireless card plug in to the pci-e port or integrated with motherboard could please explain more specificaly because i don't understand problem :)

c3s4r

2021-05-26 09:54

reporter   ~0014587

I got frustated and re-installed the kali. My usb WIFI Adapter's working fine now.
And now, I realised that I lost a chance to learn something new.
Anyway, it was a standalone os, not vm.
Also, earlier, when I plugged my usb WIFI Adapter, it was just not scanning any network. And iwconfig and ifconfig were not like this at first. Anyway, that opportunity to learn or know something new is lost now.
Thank you for your time, @Michu

c3s4r

2021-05-26 09:57

reporter   ~0014588

By the way, how can I mark this issue as closed, @Michu?

rhertzog

2021-05-27 06:59

administrator   ~0014591

Thanks for the notice, we closed the ticket.

Issue History

Date Modified Username Field Change
2021-05-12 11:28 c3s4r New Issue
2021-05-12 15:03 Michu Note Added: 0014543
2021-05-13 10:14 c3s4r Note Added: 0014546
2021-05-13 11:46 Michu Note Added: 0014547
2021-05-26 09:54 c3s4r Note Added: 0014587
2021-05-26 09:57 c3s4r Note Added: 0014588
2021-05-26 12:02 sbrun Assigned To => sbrun
2021-05-26 12:02 sbrun Status new => closed
2021-05-26 12:02 sbrun Resolution open => no change required
2021-05-27 06:58 rhertzog Status closed => resolved
2021-05-27 06:59 rhertzog Note Added: 0014591
2021-05-28 15:18 droidjamil Issue cloned: 0007206