View Issue Details

IDProjectCategoryView StatusLast Update
0007437Kali Linux[All Projects] Kali Package Bugpublic2021-11-06 11:22
Reportervanguard Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version2021.3 
Target VersionFixed in Version 
Summary0007437: orphaned entry for firmware-raspberry blocks build of kali-live
DescriptionDear maintainers,

I am running into an issue, when I want to build kali-live.
Investigation showed, that in the dependencies the entry for "firmware-raspberry" somewhere still exists, but as this package
is beeing replaced by "bluez-firmware" and now the package "firmware-raspberry" is no more available,
the build crashes due to the missing package.

It would be very nice, if you could have a look at it, maybe this can be easily fixed.

Thank you very much for your efforts.

Best regards

Hans

Additional InformationBuild.log
...
...
Purging configuration files for dctrl-tools (2.24-3) ...^M
Reading package lists...
Building dependency tree...
Reading state information...
[2021-11-03 14:46:41] lb chroot_install-packages install
P: Begin installing packages (install pass)...
Reading package lists...
Building dependency tree...
Reading state information...
Package firmware-raspberry is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  bluez-firmware

E: Package 'firmware-raspberry' has no installation candidate
E: An unexpected failure occurred, exiting...
P: Begin unmounting filesystems...
P: Saving caches...
Reading package lists...
Building dependency tree...
Reading state information...
...

Activities

arnaudr

2021-11-04 02:51

manager   ~0015406

Hi vanguard!

It's a bit strange, this particular issue was fixed one or two weeks ago already. We didn't see this error message since then, and our daily builds succeed. I just tried to build a live image on my machine (amd64 host) and it succeeds. Are you sure that everything is up to date on your side? Can you post the complete logs (including the exact command that you run), maybe I'll understand better what can go wrong?

vanguard

2021-11-06 11:22

reporter   ~0015415

Hi arnaudr,

it looks like the error is now gone. Today I tried again, this is what I did.
But please let this bugreport open for a few days more, as I want to be surem if the bug is really gone.
I am building for i386 (using on my EEEPC) and for amd64 (which is also building environment), but as my computers are not very fast, this is lasting
for hours each.

Step-by-step:

Preparations:
1. I am building using the latest kali live I build myself.

2. I deleted the whole directory "live-build-config" to get rid of old configurations, then created a new one with the command from the
kali website "git clone https://gitlab.com/kalilinux/build-scripts/live-build-config.git"

3. THIS IS IMPORTANT(!): changed into live-build-config and in this directory doing the command "lb config". For the first time this is necessary. It is creating the whole build tree (and missimng directory and configs), so you are able to change configs also before the very first build, as needed. Off topic: Maybe this should be added in the documentation of the kali site!

4. I copied my own file list into ~/live-build-config/config/package-lists

5. Last I copied some additional packages, which are not available (like jnetmap, rlinux or eeepc-acpi-scripts) into ~/live-build-config/config/package-chroot/

The Build:
1. For easy build, and so that I do not always have to download every package again, I am using apt-cacher-ng and two self created shell scripts (see attachement). The first is called "uit-update.sh", which is setting my environment (I am mounting a SSD below /mnt), installs needed packages in the live system, automatically updating the git tree, copies the acng.conf to the right place and starts apt-cacher-ng again.

2. Next I start "uit-build.sh" with the correct variable set for i386 (in this example I am building for i386, but amd64 is tunning into the same issue), environment for apt-cacher-ng, bootappends and so on. Look into the attached script, it does everything explain.

This always worked, with the only problem, that the new created live system is always starting XFCE automatically, but should start LXDE, but this issue was opened in another bugreport.

Hope, this makes things a little clearer and also helps other people.

I do not know, if there are people in the worls, which are building kali-live with similar thoughts like me, I believe, most people are building stock live kali systems with no changes, in English, no packages added, no change of environments. Doing so, of course, is well tested with nightly builds.

Thank you very much for your help.

Best regards

Hans

uit-build-i386.sh (1,885 bytes)
uit-update-kali.sh (744 bytes)

Issue History

Date Modified Username Field Change
2021-11-03 12:56 vanguard New Issue
2021-11-04 02:51 arnaudr Note Added: 0015406
2021-11-06 11:22 vanguard File Added: uit-build-i386.sh
2021-11-06 11:22 vanguard File Added: uit-update-kali.sh
2021-11-06 11:22 vanguard Note Added: 0015415