View Issue Details

IDProjectCategoryView StatusLast Update
0007445Kali Linux[All Projects] General Bugpublic2022-01-07 09:03
ReporterX0RW3LL Assigned Todaniruiz  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2021.3 
Target VersionFixed in Version 
Summary0007445: linux-image-5.14.0-kali4-amd64 breaks amdgpu
DescriptionThe latest kernel upgrade broke something with the AMD drivers. System is too slow beginning from starting gdm3.
Firefox won't start, Chromium and Settings are too slow to load.

Relevant: https://gitlab.freedesktop.org/drm/amd/-/issues/1756
Steps To ReproducePass "amd_iommu=on iommu=pt" into grub's kernel parameters. (needed to prevent a blank white screen artifact that blocks 50-100% of the display)
Upgrade to the latest kernel: linux-image-5.14.0-kali4-amd64:amd64 (5.14.16-1kali1, automatic)
Additional Information$ sudo grep 'amdgpu: failed to write' kern.log
Nov 16 03:45:44 FX kernel: [ 34.442881] amdgpu 0000:05:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
Nov 16 03:46:04 FX kernel: [ 54.455116] amdgpu 0000:05:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
Nov 16 03:46:25 FX kernel: [ 74.707065] amdgpu 0000:05:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
Nov 16 03:46:45 FX kernel: [ 94.734884] amdgpu 0000:05:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
Nov 16 03:47:06 FX kernel: [ 115.570254] amdgpu 0000:05:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
Nov 16 03:47:26 FX kernel: [ 135.577939] amdgpu 0000:05:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
Nov 16 03:47:48 FX kernel: [ 157.969775] amdgpu 0000:05:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
Nov 16 03:48:08 FX kernel: [ 177.985661] amdgpu 0000:05:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
Nov 16 03:48:35 FX kernel: [ 204.325577] amdgpu 0000:05:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
Nov 16 03:48:55 FX kernel: [ 224.341478] amdgpu 0000:05:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706

# /var/log/apt/history.log
Start-Date: 2021-11-16 03:05:32
Commandline: apt dist-upgrade -y
Requested-By: x0rw3ll (1000)
Install: linux-headers-5.14.0-kali4-amd64:amd64 (5.14.16-1kali1, automatic), libsepol2:amd64 (3.3-1, automatic), linux-image-5.14.0-kali4-amd64:amd64 (5.14.16-1kali1, automatic), gcc-11-doc:amd64 (11.2.0-1, automatic), liburing2:amd64 (2.1-2, automatic), libsepol-dev:amd64 (3.3-1, automatic), linux-headers-5.14.0-kali4-common:amd64 (5.14.16-1kali1, automatic)
Upgrade: libsphinxbase3:amd64 (0.8+5prealpha+1-12, 0.8+5prealpha+1-13), libsphinxbase3:i386 (0.8+5prealpha+1-12, 0.8+5prealpha+1-13), linux-kbuild-5.14:amd64 (5.14.9-2kali1, 5.14.16-1kali1), libselinux1-dev:amd64 (3.1-3+b1, 3.3-1), libxnvctrl0:amd64 (470.57.02-2, 470.82.00-1), gcc-doc:amd64 (5:10.1.0-2, 5:11.2.0-1), kwayland-integration:amd64 (5.23.2-1, 5.23.3-1), libidn12:amd64 (1.38-3, 1.38-4), john:amd64 (1.9.0-Jumbo-1-0kali3, 1.9.0-Jumbo-1+git20211102-0kali1), packagekit-tools:amd64 (1.2.2-2, 1.2.4-1), malcontent:amd64 (0.10.1-1, 0.10.3-1), libpipewire-0.3-common:amd64 (0.3.39-4, 0.3.40-1), containerd:amd64 (1.5.7~ds1-1, 1.5.7~ds1-2), pipewire-pulse:amd64 (0.3.39-4, 0.3.40-1), libselinux1:amd64 (3.1-3+b1, 3.3-1), libselinux1:i386 (3.1-3+b1, 3.3-1), libsasl2-modules:amd64 (2.1.27+dfsg-2.2, 2.1.27+dfsg-2.3), libsasl2-modules:i386 (2.1.27+dfsg-2.2, 2.1.27+dfsg-2.3), libmalcontent-ui-0-0:amd64 (0.10.1-1, 0.10.3-1), libsasl2-2:amd64 (2.1.27+dfsg-2.2, 2.1.27+dfsg-2.3), libsasl2-2:i386 (2.1.27+dfsg-2.2, 2.1.27+dfsg-2.3), libmalcontent-0-0:amd64 (0.10.1-1, 0.10.3-1), libibverbs1:amd64 (36.0-1, 36.0-2), linux-compiler-gcc-10-x86:amd64 (5.14.9-2kali1, 5.14.16-1kali1), libjs-jquery-ui:amd64 (1.12.1+dfsg-8, 1.13.0+dfsg-1), gcc-doc-base:amd64 (10.1.0-2, 11.2.0-1), linux-headers-amd64:amd64 (5.14.9-2kali1, 5.14.16-1kali1), pipewire:amd64 (0.3.39-4, 0.3.40-1), libsasl2-modules-db:amd64 (2.1.27+dfsg-2.2, 2.1.27+dfsg-2.3), libsasl2-modules-db:i386 (2.1.27+dfsg-2.2, 2.1.27+dfsg-2.3), malcontent-gui:amd64 (0.10.1-1, 0.10.3-1), gir1.2-packagekitglib-1.0:amd64 (1.2.2-2, 1.2.4-1), libstemmer0d:amd64 (2.1.0-2, 2.2.0-1), publicsuffix:amd64 (20210108.1309-1, 20211109.1735-1), packagekit:amd64 (1.2.2-2, 1.2.4-1), libappstream-glib8:amd64 (0.7.18-1, 0.7.18-2), python3-rich:amd64 (9.11.0-1, 10.12.0-1), python3-portend:amd64 (2.7.1-2, 3.0.0-1), linux-image-amd64:amd64 (5.14.9-2kali1, 5.14.16-1kali1), libvte-2.91-common:amd64 (0.64.2-3, 0.66.1-1), libspa-0.2-bluetooth:amd64 (0.3.39-4, 0.3.40-1), python3-sniffio:amd64 (1.1.0-1, 1.2.0-1), plocate:amd64 (1.1.13-1, 1.1.13-1+b1), gstreamer1.0-pipewire:amd64 (0.3.39-4, 0.3.40-1), python3-asciitree:amd64 (0.3.3-2, 0.3.3-3), libpackagekit-glib2-18:amd64 (1.2.2-2, 1.2.4-1), python3-h11:amd64 (0.12.0-1, 0.12.0-2), pipewire-bin:amd64 (0.3.39-4, 0.3.40-1), libcrypt-dev:amd64 (1:4.4.25-2, 1:4.4.26-1), nvidia-settings:amd64 (470.57.02-2, 470.82.00-1), libcrypt1:amd64 (1:4.4.25-2, 1:4.4.26-1), libcrypt1:i386 (1:4.4.25-2, 1:4.4.26-1), john-data:amd64 (1.9.0-Jumbo-1-0kali3, 1.9.0-Jumbo-1+git20211102-0kali1), python3-ply:amd64 (3.11-4, 3.11-5), libsemanage-common:amd64 (3.1-2, 3.3-1), gir1.2-malcontent-0:amd64 (0.10.1-1, 0.10.3-1), ibverbs-providers:amd64 (36.0-1, 36.0-2), eyewitness:amd64 (20211025.1-0kali1, 20211110.1-0kali1), libspa-0.2-modules:amd64 (0.3.39-4, 0.3.40-1), libpipewire-0.3-modules:amd64 (0.3.39-4, 0.3.40-1), librdmacm1:amd64 (36.0-1, 36.0-2), gir1.2-vte-2.91:amd64 (0.64.2-3, 0.66.1-1), libvte-2.91-0:amd64 (0.64.2-3, 0.66.1-1), iproute2:amd64 (5.14.0-1, 5.15.0-1), python3-tempora:amd64 (4.1.1-2, 4.1.2-1), linux-libc-dev:amd64 (5.14.9-2kali1, 5.14.16-1kali1), libpipewire-0.3-0:amd64 (0.3.39-4, 0.3.40-1)
Remove: libsepol1-dev:amd64 (3.1-1)
End-Date: 2021-11-16 03:09:21

$ sudo inxi -G #grabbed from the older bootable image
Graphics: Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] driver: nvidia v: 470.82.00
                   Device-2: Advanced Micro Devices [AMD/ATI] Picasso driver: amdgpu v: kernel
                   Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
                   Display: server: X.Org 1.20.11 driver: loaded: amdgpu,ati,nvidia unloaded: fbdev,modesetting,nouveau,vesa
                   resolution: 1920x1080~120Hz
                   OpenGL: renderer: AMD Radeon Vega 10 Graphics (RAVEN DRM 3.42.0 5.14.0-kali2-amd64 LLVM 12.0.1) v: 4.6 Mesa 21.2.5

$ neofetch --off #grabbed from the older bootable image
OS: Kali GNU/Linux Rolling x86_64
Host: TUF Gaming FX505DU_FX95DU 1.0
Kernel: 5.14.0-kali2-amd64
Uptime: 35 mins
Packages: 3998 (dpkg), 8 (snap)
Shell: bash 5.1.8
Resolution: 1920x1080
DE: GNOME 41.0
WM: Mutter
WM Theme: Kali-Dark
Theme: Flat-Remix-GTK-Blue-Dark [GTK2/3]
Icons: Flat-Remix-Blue-Dark [GTK2/3]
Terminal: tilix
CPU: AMD Ryzen 7 3750H with Radeon Vega Mobile Gfx (8) @ 2.300GHz
GPU: NVIDIA GeForce GTX 1660 Ti Mobile
GPU: AMD ATI 05:00.0 Picasso
Memory: 3222MiB / 15435MiB

Relationships

related to 0007447 resolveddaniruiz Bug in kernel version linux-image-5.14.0-kali4-amd64 
related to 0007486 resolveddaniruiz Kali is slow to boot after dist-upgrade 

Activities

X0RW3LL

2021-11-17 10:43

reporter   ~0015432

Update: issue occurs when laptop is plugged in. Everything works fine if I'm booting up on battery.

VT

2021-11-17 12:59

reporter   ~0015433

I have the same issues on PC so I rolled back to previous version. Looks like a bug in 5.14.16 kernel

g0tmi1k

2021-11-20 16:12

administrator   ~0015441

Debian bug report https://lists.debian.org/debian-kernel/2021/11/msg00071.html ?

X0RW3LL

2021-11-20 16:50

reporter   ~0015442

Yep. Hopefully they push that out soon.
Thank you so much for the reply! Please feel free to close/change the status of the issue as you see fit.

Johnlabo

2021-11-20 18:19

reporter  

kali-nethunter-app-master.tar.gz (860,539 bytes)

Jey-Be

2021-12-21 17:58

reporter   ~0015553

I was really patient for a long time, but it seams the Kali team totally forgot/ignored this bug affecting many AMD users? Most of them, like me, didn't report when there are already 3 bug reports. It was first reported on 2021-11-17 (Bug-ID 7447) and according to https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=998799 it was already fixed in 5.15 kernel more than a month ago in Debians kernel! I really don't understand how Kali Linux 2021.4 could be released with such a dramatic known bug when a fix is available - or am I wrong? Unluckily new installations can't choose an old kernel in the boot menu as workaround. That way you force people to use BlackArch or buy another expensive lab extension of the OSCP course because most of the time you need to fix bugs for yourself (already had big problems with the VMware Image so decided to install Kali native but Kali is still full of bugs).

X0RW3LL

2021-12-21 18:01

reporter   ~0015554

Bear in mind that porting kernel images is a massive PITA, and the team already has more than enough on their plates.
In the mean time, you can either disconnect your charger during the boot sequence, or keep using the old kernel images until we get the new kernel update.

X0RW3LL

2021-12-30 09:06

reporter   ~0015585

Update: 5.15.5-2kali2 fixed the issue. This issue can now be closed.

Many thanks!

Issue History

Date Modified Username Field Change
2021-11-16 11:54 X0RW3LL New Issue
2021-11-17 10:43 X0RW3LL Note Added: 0015432
2021-11-17 12:59 VT Note Added: 0015433
2021-11-20 16:12 g0tmi1k Note Added: 0015441
2021-11-20 16:50 X0RW3LL Note Added: 0015442
2021-11-20 18:19 Johnlabo File Added: kali-nethunter-app-master.tar.gz
2021-12-21 17:58 Jey-Be Note Added: 0015553
2021-12-21 18:01 X0RW3LL Note Added: 0015554
2021-12-30 09:06 X0RW3LL Note Added: 0015585
2022-01-03 15:35 daniruiz Assigned To => daniruiz
2022-01-03 15:35 daniruiz Status new => resolved
2022-01-03 15:35 daniruiz Resolution open => fixed
2022-01-07 09:03 daniruiz Relationship added related to 0007447
2022-01-07 09:03 daniruiz Relationship added related to 0007486