View Issue Details

IDProjectCategoryView StatusLast Update
0007474Kali Linux[All Projects] Kali Package Bugpublic2022-03-25 13:58
Reportercohst Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version2021.3 
Target VersionFixed in Version 
Summary0007474: lightdm stopped working after update
DescriptionAfter apt update && apt dist-upgrade on 04th December 2021 on Dell Latitude Notebook lightdm can't be started on boot or during run. See screenshots attached. I've found out that the dbus package changed in October an maybe this is part of the problem, because lightdm does not seem to be changed. But anyway starting the graphical desktop interface is not possible anymore.
Steps To ReproduceUpdate to latest kali packages.
Additional InformationScreenshots

Activities

cohst

2021-12-05 08:17

reporter  

kali lightdm error.jpg (8,656 bytes)
kali lightdm error.jpg (8,656 bytes)

arnaudr

2021-12-06 10:36

manager   ~0015489

Hi, the second screenshot is too small to be readable, can you upload it again with higher resolution? Thanks!

cohst

2021-12-07 17:58

reporter  

Screenshot.JPG (136,676 bytes)
Screenshot.JPG (136,676 bytes)

cohst

2021-12-07 17:59

reporter   ~0015490

See attached screenshot. From my point of view it seems as dependencies of dbus lead to this problem here.

arnaudr

2021-12-08 02:20

manager   ~0015491

The error is at the line:

XServer 0: Can't launch X server X, not found in path


Did you check if there's more information in the log file /var/log/lightdm-/x-0.log?

Other than that, I have no idea what went wrong. I would just try something like "apt update && apt full-upgrade" and make sure that apt doesn't report any error. Then maybe try to re-install the packages that seem to be related to this error, maybe "apt install --reinstall lightdm xorg xserver-xorg xserver-xorg-core". Not tested, but I guess it can't hurt.

Even if the dbus package changed, I don't think it's related to the issue you're having (just my feeling).

cohst

2021-12-18 12:06

reporter   ~0015543

I have re-installed KAli Linux from the scratch and then did apt-get update && apt-get full-upgrade and upgraded to the latest edition and everything works. I don't really know what exactly it was, but could image it had something to do with dependencies because the old installation was a bit "handicraft".

You can close this ticket here, thanks for your help.

matthew.crabb@walthamforest.gov.uk

2022-02-03 15:03

reporter   ~0015686

I have the same issue after an upgrade, I'm no expert but I believe both issues I am experiencing are linked to libglib2 xorg and lightdm-gtk-greeter are both broken.

 x-0.log
MESA-LOADER: failed to open bochs-drm: /usr/lib/dri/bochs-drm_dri.so: cannot open shared object file: No such file or directory

seat0-greeter.log
/usr/sbin/lightdm-gtk-greeter: symbol lookup error: /usr/lib/x86_64-linux-gnu/libpango-1.0.so.0: undefined symbol: g_memdup2

Thanks

arnaudr

2022-03-11 04:46

manager   ~0015864

Hi and sorry for the late reply,

After a quick search regarding your MESA-LOADER error, I found this link: https://www.mail-archive.com/blfs-dev@lists.linuxfromscratch.org/msg10659.html. Based on that, the issue should be fixed with glib 2.68.1, which is in Kali 2022.1 and also in Kali Rolling.

Are you sure your Kali system is up-to-date? No error when you run "sudo apt update && sudo apt full-upgrade"?

Also, please check the installed version of libglib on your system by running the command "apt show libglib2.0-0" in a terminal, and paste the output here. Thanks!

matthew.crabb@walthamforest.gov.uk

2022-03-11 09:15

reporter   ~0015867

Hi

Thanks for the response, I run another upgrade to 2022.1 and this went through fine the issue seems to be somehow the version of glib is libglib2.0 is 2.70.4-1

root@wfkali:~# apt show libglib2.0-0
Package: libglib2.0-0
Version: 2.70.4-1
Priority: optional
Section: libs
Source: glib2.0
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian. org>
Installed-Size: 4,164 kB
Depends: libc6 (>= 2.33), libffi8 (>= 3.4), libmount1 (>= 2.35.2-7~), libpcre3, libselinux1 (>= 3.1~), zlib1g (>= 1:1.2.2)
Recommends: libglib2.0-data, shared-mime-info, xdg-user-dirs
Breaks: gimp (<< 2.10.14-3~), glib-networking-tests (<< 2.70.0~), gnome-keyring (<< 40.0-3~), libgirepository-1.0-1 (<< 1.62.0-4~), libgladeui-2-6 (<< 3.22.2), libsoup2.4-tests (<< 2.72.0-3~)
Homepage: https://wiki.gnome.org/Projects/GLib
Tag: role::shared-lib
Download-Size: 1,405 kB
APT-Manual-Installed: yes
APT-Sources: http://http.kali.org/kali kali-rolling/main amd64 Packages
Description: GLib library of C routines
 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package contains the shared libraries.

Issue History

Date Modified Username Field Change
2021-12-05 08:17 cohst New Issue
2021-12-05 08:17 cohst File Added: error log lightdm display manager.jpg
2021-12-05 08:17 cohst File Added: kali lightdm error.jpg
2021-12-06 10:36 arnaudr Note Added: 0015489
2021-12-07 17:58 cohst File Added: Screenshot.JPG
2021-12-07 17:59 cohst Note Added: 0015490
2021-12-08 02:20 arnaudr Note Added: 0015491
2021-12-18 12:06 cohst Note Added: 0015543
2022-02-03 15:03 matthew.crabb@walthamforest.gov.uk Note Added: 0015686
2022-03-11 04:46 arnaudr Note Added: 0015864
2022-03-11 09:15 matthew.crabb@walthamforest.gov.uk Note Added: 0015867
2022-03-25 13:50 g0tmi1k Priority high => normal
2022-03-25 13:57 g0tmi1k Severity crash => feature
2022-03-25 13:58 g0tmi1k Severity feature => minor