View Issue Details

IDProjectCategoryView StatusLast Update
0008453Kali LinuxKali Package Improvementpublic2023-09-06 07:02
ReporterFryTheSolid Assigned To 
Status newResolutionopen 
Product Version2023.3 
Summary0008453: Alfa AWUS036ACHM does not seem to work in Kali 2023.3

I picked an adapter form but it does not seem to work in the current Kali version. Based on other posts it does seem like it was plug and play in 2022.x. I reached out for help on Discord and it was recommended that I open a bug report.

I tried cloning 'git clone git://' and it now looks like it's loading but still not visible in 'iwconfig'.

[ 68.352895] usb 1-1: reset high-speed USB device number 2 using ehci-pci
[ 68.716959] mt76x0u 1-1:1.0: ASIC revision: 76100002 MAC revision: 76502000
[ 68.727665] mt76x0u 1-1:1.0: firmware: direct-loading firmware mediatek/mt7610e.bin

kali@kali:~$ lsusb
Bus 001 Device 002: ID 0e8d:7610 MediaTek Inc. WiFi

Steps To Reproduce

Attach adapter, with the default mediatek drive it failed with...

[ 90.092928] mt76x0u 2-2:1.0: firmware: direct-loading firmware mediatek/mt7610e.bin
[ 93.303149] mt76x0u 2-2:1.0: vendor request req:06 off:0800 failed:-110
[ 96.205879] mt76x0u 2-2:1.0: firmware upload failed: -110
[ 96.624179] mt76x0u: probe of 2-2:1.0 failed with error -110

After changing the driver out it seems to load but the adapter is not visible.

Additional Information

Win 11 host, VM Workstation Pro 17.0.2 build-21581411




2023-09-06 07:02

manager   ~0018445

A quick look at the file mediatek/mt7610e.bin in linux-firmware tells me that this file was not modified since it was added in Oct 2018. So I don't think the failure is due to a change in Kali 2023.3.

The error code that you get (-110) could mean timeout, although I'm not sure.

You run Kali in VMware, so my guess would be that the USB device can't communicate with the VM for some reason. Maybe USB devices won't work out-of-the-box in the VM, you might need to tweak the configuration of the VM, maybe enable something called "USB passthrough" if that exists. Maybe this answer can get you started.

Issue History

Date Modified Username Field Change
2023-09-05 23:23 FryTheSolid New Issue
2023-09-06 07:02 arnaudr Note Added: 0018445