View Issue Details

IDProjectCategoryView StatusLast Update
0008299Kali Linux[All Projects] General Bugpublic2023-05-24 01:14
Reporterderpmerp111 Assigned Toarnaudr  
PriorityhighSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionfixed 
Product Version2023.1 
Target VersionFixed in Version2023.2 
Summary0008299: 0008250: No sound on kali 2023.1
DescriptionI am using Linux 6.1.0-kali7-amd64 kernel - Debian release and tried everything but still no sound after the upgrade.


has duplicate 0008301 closedarnaudr 0008250: No sound on kali 2023.1 
has duplicate 0008315 resolvedarnaudr No sound on Kali 2023.2 



2023-05-13 00:10



2023-05-14 06:29

reporter   ~0017920

I have the same issue after doing an dist-upgrade, same kernel as derp, pipewire is running via ps. Pulseaudio was running successfully before the upgrade, I was on at least a year old version.


2023-05-14 08:21

reporter   ~0017921

Duplicate of 0008195, 0008258 and/or 0008246?


2023-05-16 03:14

manager   ~0017935

Please paste the output of the command: « dpkg -l | grep -E 'blue[tz]|pipewire|wireplumber|pulse' ». That will help to make sure that all the required packages are installed.

user988098217490: Please paste the output of « ps -fp $(pgrep wire) » (as did the OP above). That will help to confirm that the right services are running.

derpmerp111: I see in your screenshot that you're root. Did you login as root? If so, please try to login as the unprivileged user, and check whether sound works.

Apart from that, feel free to provide more details: which desktop do you use (XFCE, GNOME, KDE) ? Do you run Kali in a VM, or baremetal ? Also please confirm that we're talking about sound over speakers or wired headset, and that there's no bluetooth device in this story. Thanks!


2023-05-18 02:29

reporter   ~0017957


└─$ dpkg -l | grep -E 'blue[tz]|pipewire|wireplumber|pulse'
ii blueman 2.3.5-2+b1 amd64 Graphical bluetooth manager
ii bluez 5.66-1+kali1 amd64 Bluetooth tools and daemons
ii bluez-firmware 1.2-9 all Firmware for Bluetooth devices
ii bluez-hcidump 5.66-1+kali1 amd64 Analyses Bluetooth HCI packets
ii bluez-obexd 5.66-1+kali1 amd64 bluez obex daemon
ii kismet-capture-linux-bluetooth 2022.08.R1-0kali3 amd64 Kismet Linux Bluetooth capture helper
ii libbluetooth3:amd64 5.66-1+kali1 amd64 Library to use the BlueZ Linux Bluetooth stack
ii libpipewire-0.3-0:amd64 0.3.65-3 amd64 libraries for the PipeWire multimedia server
ii libpipewire-0.3-common 0.3.65-3 all libraries for the PipeWire multimedia server - common files
ii libpipewire-0.3-modules:amd64 0.3.65-3 amd64 libraries for the PipeWire multimedia server - modules
ii libpulse-mainloop-glib0:amd64 16.1+dfsg1-2+b1 amd64 PulseAudio client libraries (glib support)
ii libpulse0:amd64 16.1+dfsg1-2+b1 amd64 PulseAudio client libraries
ii libpulsedsp:amd64 16.1+dfsg1-2+b1 amd64 PulseAudio OSS pre-load library
ii libspa-0.2-bluetooth:amd64 0.3.65-3 amd64 libraries for the PipeWire multimedia server - bluetooth plugins
ii pipewire:amd64 0.3.65-3 amd64 audio and video processing engine multimedia server
ii pipewire-bin 0.3.65-3 amd64 PipeWire multimedia server - programs
ii pipewire-media-session 0.4.2-3 amd64 example session manager for PipeWire
ii pipewire-pulse 0.3.65-3 amd64 PipeWire PulseAudio daemon
ii pulseaudio 16.1+dfsg1-2+b1 amd64 PulseAudio sound server
ii pulseaudio-module-bluetooth 16.1+dfsg1-2+b1 amd64 Bluetooth module for PulseAudio sound server
ii pulseaudio-utils 16.1+dfsg1-2+b1 amd64 Command line tools for the PulseAudio sound server
ii xfce4-pulseaudio-plugin:amd64 0.4.5-1 amd64 Xfce4 panel plugin to control pulseaudio

└─$ ps -fp $(pgrep wire)
myusername 1427 1411 0 21:23 ? S<sl 0:00 /usr/bin/pipewire
myusername 1428 1411 0 21:23 ? Ssl 0:00 /usr/bin/pipewire-media-session
myusername 1429 1411 0 21:23 ? S<sl 0:00 /usr/bin/pipewire-pulse

Running i3, Baremetal, Headphones do not work, Speakers do not work, No bluetooth devices in use.


2023-05-18 02:50

manager   ~0017958

Thanks for feedback, can you please also run this command: « apt list '?installed !?automatic' | grep pipe » ? THanks!


2023-05-18 20:11

reporter   ~0017972

Thank you for the help, output below

└─$ apt list '?installed !?automatic' | grep pipe

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

So I ran instead
└─$ apt list '?installed !?automatic' > output; grep pipe output; echo "============ tailing to show file has content from apt list command\n"; tail -n4 output

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

============ tailing to show file has content from apt list command

zlib1g/kali-rolling,now 1:1.2.13.dfsg-1 amd64 [installed]
zsh-autosuggestions/kali-rolling,now 0.7.0-1 all [installed]
zsh-syntax-highlighting/kali-rolling,now 0.7.1-2 all [installed]
zsh/kali-rolling,now 5.9-4+b1 amd64 [installed]

It appears the grep would not have matched anything from the apt list command.

Which I guess is a bit odd since that should have shown some of the pipewire installed packages.


2023-05-19 01:28

manager   ~0017974

Heya! So this command « apt list '?installed !?automatic' » is about listing the packages that were installed MANUALLY. I wanted to know if you installed the package pipewire-media-session manually, because I'm trying to understand why this package is still installed on your system, and wireplumber is not installed. I think that's what causes the sound issue.

If you get no output when running the command above, it means you didn't manually install any package with 'pipe' in the name. And that's, well, pretty normal. To clarify: the pipewire packages that are on your system were not installed manually, they were installed because they are dependencies of other packages.

But I'm still left wondering why wireplumber was not installed when you upgrade... Do you remember if you run "apt upgrade" or "apt full-upgrade", by any chance? (you should always run "apt full-upgrade" BTW, "apt upgrade" is not really the right command to update a system, I know it's confusing...)

Anyway, end of the explanations. What's next? I might have fixed it via the latest version of the metapackage kali-desktop-xfce.

Please upgrade your system again « apt update && apt full-upgrade ». Pay attention to the output before hitting Enter. You should see that pipewire-media-session will be removed, wireplumber will be installed, and kali-desktop-xfce (among many other packages) will be upgraded. Is it the case? If so, confirm, lets the system upgrade, then log out and log back in. Does sound work now? If not, try a full restart. Does the sound work?

Thanks very much for following up so far and helping to troubleshoot the issue. This is much appreciated!


2023-05-23 15:12

reporter   ~0018003



2023-05-23 20:43

reporter   ~0018007

I ran apt upgrade instead of apt full-upgrade, and thank you for that pointer I have been doing it wrong all along.

I will try your recommendations now.


2023-05-23 20:47

reporter   ~0018008

apt full-upgrade

The following packages will be REMOVED:
The following NEW packages will be installed:
  libwireplumber-0.4-0 linux-headers-6.1.0-kali9-amd64 linux-headers-6.1.0-kali9-common linux-image-6.1.0-kali9-amd64 wireplumber
The following packages have been kept back:

Interesting to see the metapackage you mention showing up as being kept back, not exactly sure why that would happen. Probably a lack of understanding of apt on my part :)

Will report back after install completes and I re-login.


2023-05-23 21:22

reporter   ~0018009

Logging out and logging back in did not get sound to work,

but a full reboot did!

Thank you for the patience and detailed advice. Now I can listen to Lofi again haha.


2023-05-24 01:08

manager   ~0018011

> Interesting to see the metapackage you mention showing up as being kept back

So indeed, this "kali-desktop-xfce has been kept back" issue was reported yesterday, and I think I fixed it. But at the time you tested it, the latest package was not available in the repo yet.

If you try again to run « sudo apt update && sudo apt full-upgrade -V » (note the -V for verbose, it will show package versions), it should now upgrade the package kali-desktop-xfce to 2023.2.11. No more « kept back ».

Many many thanks for following up until the end user988098217490, whoever you are :D It really helped a lot. This transition from pulseaudio to pipewire was more tricky than it seemed, but I think now we solved all the issues.

I'm closing the ticket. Thanks again for your help!


2023-05-24 01:14

manager   ~0018012

BTW: if kali-desktop-xfce is still "held back" with version 2023.2.11, then you can try « sudo apt install kali-desktop-xfce ». By asking explicitly to upgrade this package (yes, 'apt install' will also upgrade packages if they are already installed), apt will try harder to propose a solution. Watch out for the output thought, if apt wants to remove a ton of packages, don't hit Enter...

Issue History

Date Modified Username Field Change
2023-05-13 00:10 derpmerp111 New Issue
2023-05-13 00:10 derpmerp111 File Added: Screenshot_2023-05-12_19-10-12.png
2023-05-14 06:29 user988098217490 Note Added: 0017920
2023-05-14 08:21 kali-bugreport Note Added: 0017921
2023-05-14 20:44 Fasal Issue cloned: 0008301
2023-05-16 03:14 arnaudr Note Added: 0017935
2023-05-17 01:26 arnaudr Relationship added has duplicate 0008301
2023-05-18 02:29 user988098217490 Note Added: 0017957
2023-05-18 02:50 arnaudr Note Added: 0017958
2023-05-18 13:20 daniruiz Relationship added has duplicate 0008315
2023-05-18 20:11 user988098217490 Note Added: 0017972
2023-05-19 01:28 arnaudr Note Added: 0017974
2023-05-23 15:12 khairul Note Added: 0018003
2023-05-23 20:43 user988098217490 Note Added: 0018007
2023-05-23 20:47 user988098217490 Note Added: 0018008
2023-05-23 21:22 user988098217490 Note Added: 0018009
2023-05-24 01:08 arnaudr Note Added: 0018011
2023-05-24 01:08 arnaudr Assigned To => arnaudr
2023-05-24 01:08 arnaudr Status new => assigned
2023-05-24 01:08 arnaudr Status assigned => resolved
2023-05-24 01:08 arnaudr Resolution open => fixed
2023-05-24 01:08 arnaudr Fixed in Version => 2023.2
2023-05-24 01:14 arnaudr Note Added: 0018012