View Issue Details

IDProjectCategoryView StatusLast Update
0005468Kali Linux[All Projects] Tool Upgradepublic2019-09-12 08:33
Reporterj_jitoAssigned Tosbrun 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2019.2 
Target VersionFixed in Version 
Summary0005468: [Tool Upgrade] KeepassXC update 2.4.1
DescriptionCan you please update KeepassXC from version 2.3.4+dfsg.1-1 -> 2.4.1

Activities

j_jito

2019-05-30 10:59

reporter   ~0010644

Changelog:

- Fix database deletion when using unsafe saves to a different file system
- Fix opening databases with legacy key files that contain ‘/’
- Fix opening database files from the command line
- Fix crash when editing master key
- Fix multiple issues with apply button behavior
- Fix issues on application startup (tab order, –pw-stdin, etc.)
- Fix building without WITH_XC_KEESHARE
- Fix reference entry coloring on macOS dark mode
- Hide window when performing entry auto-type on macOS
- Improve UX of update checker; reduce checks to every 7 days
- KeeShare improvements
- Re-enable Ctrl+C to copy password from search box
- Add KeePassXC-Browser integration for Brave browser
- SSH Agent: Re-Add keys on database unlock
- SSH Agent: Only remove keys on app exit if they are removed on lock
- CLI: Add –no-password option
- CLI: Improve database extraction to XML
- CLI: Don’t call mandb on build
- CLI: Add debug info
- Improve support for Snap theming
- Add support for building on Haiku OS
- Ctrl+PgDn now goes to the next tab and Ctrl+PgUp to the previous
- Fix compiling on GCC 5 / Xenial
- Add .gitrev output to tarball for third-party builds
- Add WITH_XC_UPDATECHECK compile flag to toggle the update checker

j_jito

2019-06-01 11:26

reporter   ~0010645

KeepassXC 2.4.2
Changelog:

Improve resilience against memory attacks - overwrite memory before free [0003020]
Prevent infinite save loop when location is unavailable [#3026]
Attempt to fix quitting application when shutdown or logout issued [0003199]
Support merging database custom data [#3002]
Fix opening URL’s with non-http schemes [#3153]
Fix data loss due to not reading all database attachments if duplicates exist [0003180]
Fix entry context menu disabling when using keyboard navigation [0003199]
Fix behaviors when canceling an entry edit [0003199]
Fix processing of tray icon click and doubleclick [0003112]
Update group in preview widget when focused [0003199]
Prefer DuckDuckGo service over direct icon download (increases resolution) [#2996]
Remove apply button in application settings [0003019]
Use winqtdeploy on Windows to correct deployment issues [0003025]
Don’t mark entry edit as modified when attribute selection changes [0003041]
Use console code page CP_UTF8 on Windows if supported [0003050]
Snap: Fix locking database with session lock [#3046]
Snap: Fix theming across Linux distributions [0003057]
Snap: Use SNAP_USER_COMMON and SNAP_USER_DATA directories [0003131]
KeeShare: Automatically enable WITH_XC_KEESHARE_SECURE if quazip is found [0003088]
macOS: Fix toolbar text when in dark mode [0002998]
macOS: Lock database on switching user [0003097]
macOS: Fix global Auto-Type when the database is locked [0003138]
Browser: Close popups when database is locked [0003093]
Browser: Add tests [0003016]
Browser: Don’t create default group if custom group is enabled [0003127]

sbrun

2019-09-12 08:33

manager   ~0011082

new version 2.4.3+dfsg.1-1 is now in kali-rolling

Issue History

Date Modified Username Field Change
2019-05-30 10:50 j_jito New Issue
2019-05-30 10:50 j_jito Status new => assigned
2019-05-30 10:50 j_jito Assigned To => sbrun
2019-05-30 10:59 j_jito Note Added: 0010644
2019-06-01 11:26 j_jito Note Added: 0010645
2019-09-12 08:33 sbrun Status assigned => resolved
2019-09-12 08:33 sbrun Resolution open => fixed
2019-09-12 08:33 sbrun Note Added: 0011082