View Issue Details

IDProjectCategoryView StatusLast Update
0006053Kali Linux[All Projects] Kali Package Bugpublic2020-02-16 15:12
ReporterDanishzahid Assigned Torhertzog  
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2020.1 
Target VersionFixed in Version2020.1 
Summary0006053: Not starting after installation
DescriptionAfter installation this things is appearing 'kali gnu/linux rolling kali tty1 kali login" I have install kali many times but many times it's appearing many of the users got this issue but no one got the solution I have tried startx it's showing command unkown plz resolve this issue

Relationships

has duplicate 0006058 closedrhertzog No GUI after installation 
has duplicate 0006061 closedrhertzog Stuck on kali login tty1 Try to install again and again and still not find the right solution please share the response 
has duplicate 0006062 closedrhertzog Help solve it soon as many have the same error 
has duplicate 0006066 closedrhertzog I get stuck in the kali tty1 login 
has duplicate 0006063 closedrhertzog Help solve it soon as many have the same error 

Activities

rhertzog

2020-02-05 14:11

administrator   ~0012013

Can you let us know which ISO image you used to install your system?

DId you have working network while doing the installation? What kind of network are you using ?

Can you attach the file /var/log/installer/syslog from your installed system?

Danishzahid

2020-02-06 06:16

reporter   ~0012031

I have again install but showing that same issue plz resolve this or tell a way to overcome this issue I'm waiting... I have downloaded the latest iso kali amd 64 2020.1

PhotoPictureResizer_200206_114320851_crop_2418x2061.jpg (1,013,616 bytes)

rhertzog

2020-02-06 13:24

administrator   ~0012032

You are not helping us by answering only parts of the questions. We have 3 ISOs for amd64 in version 2020.1 and you're not telling us which one (live ISO, normal installer, netinst installer). I had three more questions that you skipped.

The screen that you get is a terminal, you can login with the account that you created during installation and you can perform various tasks on the command line, including copying the file that I requested.

Alternatively you can download that file during the installation, close to the end, by using the back button instead of the next one and selecting the appropriate entry in the main menu:
https://www.kali.org/docs/troubleshooting/troubleshooting-a-kali-linux-install/

Danishzahid

2020-02-06 17:53

reporter   ~0012033

I have installed kali amd 64 live I have login but only command line are coming not the desktop plz help sir...

rhertzog

2020-02-07 10:24

administrator   ~0012039

When you install with the live ISO or with the "netinst" ISO, make sure that you have working network configured during installation otherwise you will not be able to install anything except the bare minimum giving you only console access.

rhertzog

2020-02-11 09:36

administrator   ~0012202

For the record, we switched back to the usual installer in the live ISO so the next daily/weekly images will get the former behaviour of installing exactly what's available in the live ISO. Hopefully this will resolve the issue for all of you who did not understand why you did not get anything installed.

http://cdimage.kali.org/kali-weekly/ (next weekly will be 2020-W08)

MegaBurn

2020-02-12 05:16

reporter   ~0012262

I'm having the same problem, 2 systems, repeatable.
Image used: kali-linux-2020.1-installer-amd64.iso
Offline install, NIC present, cable not connected, no network configured.
Installer syslog attached.

Steps to repeat: Create VirtualBox guest with minimum specs (2 core, no cap, 4GB RAM, 128MB VRAM, 20GB storage, 1 NIC NAT cable not connected, etc), load installer ISO file, boot VM, run through atypical basic install with defaults at all steps, no network config, no network mirror, host kalivbox, user kalivbox, all-in-one partition, at software selection leave default boxes checked (or check all boxes, makes no difference). When done, reboot, and there's no GUI, only command-line login.

Further testing: Login, enter "startx" but bash says command not found. Enter "start"+tab+tab and it offers start-pulseaudio-x11, start-statd, start-stop-daemon, and startxfce4. Enter "startxfce4" and it says "Starting X server" then "122: exec: xinit: not found".

Syslog Notes: This is repeated thousands of times early in the file, before install begins: Feb 12 02:12:54 in-target: depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/lib/modules/5.4.0-kali2-amd64/modules.builtin.bin'^M

Further notes: This started on my dedicated Kali laptop, I foolishly wiped & installed without testing the image in Vbox, twice, first with the live image, then saw the blog post about live being reduced to net install only, and again with the full installer image. VirtualBox test with v6.1.2. In all cases its a basic install in a offline environment (NIC present but LAN not configured). Installer offers no errors, live installer offers no clues its a minimal install. Both the installer image check sum is good, and advanced installer media validation is good. My guess is install script is missing packages.

Also, my laptop also complained about missing firmware iwlwifi-4965-2.ucode , I found it in firmware-iwlwifi_20190717-2_all.deb , installer offered no indication if it used the file or not.

Comment: For me an offline install is required, only internet here is slow dialup over ancient noisy Frontier phone lines, 26.4kbp, ~3.2kB/s, but I have occasional access to 50Mbps wifi a ~30min drive away. I have to use my laptop to shuttle packages in for updates or installs, sucks, can't wait for SpaceX Starlink.

Hope that helps,
Thanks

syslog.gz (183,382 bytes)

rhertzog

2020-02-12 22:13

administrator   ~0012265

Ok, confirmed, for some reason the xserver-xorg package is not installed and lightdm thus fails to start. The xserver-xorg package is however available in the ISO so the lack of the network is not the problem here. And lightdm properly Recommends that package so it should be picked up.

I will have to investigate, I know that d-i is disabling Recommends in some places, maybe that's the problem here. We could work-around it and add a proper dependency in our kali-desktop-xfce meta-package. However, but that doesn't sound entirely right.

rhertzog

2020-02-13 13:03

administrator   ~0012271

Investigating further I see that xserver-xorg is not installed because one of its dependencies "xserver-xorg-input-all" is not available. And indeed it seems to be missing. Now analyzing the logs of simple-cdd/debian-cd to find out why this package is not included:

    xserver-xorg Dep: (OR xserver-xorg-input-all xorgxrdp xserver-xorg-input-aiptek xserver-xorg-input-elographics xserver-xorg-input-evdev xserver-xorg-input-evdev-udeb xserver-xorg-input-joystick xserver-xorg-input-kbd xserver-xorg-input-libinput xserver-xorg-input-libinput-udeb xserver-xorg-input-mouse xserver-xorg-input-mtrack xserver-xorg-input-multitouch xserver-xorg-input-mutouch xserver-xorg-input-synaptics xserver-xorg-input-void xserver-xorg-input-wacom xserver-xorg-input-xwiimote ) soft_depend 1
    xserver-xorg-input-all not included in a useful version, check_backports 0
    xorgxrdp not included in a useful version, check_backports 0
    xserver-xorg-input-aiptek not included in a useful version, check_backports 0
    xserver-xorg-input-elographics not included in a useful version, check_backports 0
    xserver-xorg-input-evdev not included in a useful version, check_backports 0
    xserver-xorg-input-evdev-udeb not included in a useful version, check_backports 0
    xserver-xorg-input-joystick not included in a useful version, check_backports 0
    xserver-xorg-input-kbd not included in a useful version, check_backports 0
    xserver-xorg-input-libinput not included in a useful version, check_backports 0
      xserver-xorg-input-libinput-udeb is included already, acceptable version 0.29.0-1

So it seems that debian-cd believes that xserver-xorg-input-libinput-udeb can satisfy the dependency... but that package is not part of the main archive, it's part of the debian-installer archive. And debian-cd is mixing both together for the sake of dependency resolution...

Danishzahid

2020-02-13 13:12

reporter   ~0012272

Sir then what should I do....

rhertzog

2020-02-13 14:56

administrator   ~0012275

I fixed this problematic behaviour in debian-cd 3.1.29~kali1 that I just uploaded. I will look into generating 2020.1a full installer images.

rhertzog

2020-02-13 15:00

administrator   ~0012276

@Danishzahid Use this ISO: https://archive.kali.org/kali-daily-images/kali-linux-rolling-live-amd64.iso

rhertzog

2020-02-13 21:36

administrator   ~0012279

FTR here's the relevant commit fixing this issue: https://salsa.debian.org/images-team/debian-cd/commit/7ea13858fb294b6f3f12c48da0f70cbee10be290

rhertzog

2020-02-16 15:12

administrator   ~0012283

You can use the following fixed ISO: http://cdimage.kali.org/kali-2020.1/kali-linux-2020.1a-installer-amd64.iso (same for i386)

Issue History

Date Modified Username Field Change
2020-02-01 09:01 Danishzahid New Issue
2020-02-05 14:11 rhertzog Assigned To => rhertzog
2020-02-05 14:11 rhertzog Status new => feedback
2020-02-05 14:11 rhertzog Note Added: 0012013
2020-02-05 14:25 rhertzog Relationship added has duplicate 0006058
2020-02-05 14:30 rhertzog Relationship added has duplicate 0006061
2020-02-05 14:31 rhertzog Relationship added has duplicate 0006062
2020-02-05 14:35 rhertzog Relationship added has duplicate 0006066
2020-02-06 06:16 Danishzahid File Added: PhotoPictureResizer_200206_114320851_crop_2418x2061.jpg
2020-02-06 06:16 Danishzahid Note Added: 0012031
2020-02-06 06:16 Danishzahid Status feedback => assigned
2020-02-06 13:24 rhertzog Note Added: 0012032
2020-02-06 17:53 Danishzahid Note Added: 0012033
2020-02-07 10:20 rhertzog Relationship added has duplicate 0006063
2020-02-07 10:24 rhertzog Note Added: 0012039
2020-02-11 09:36 rhertzog Note Added: 0012202
2020-02-12 05:16 MegaBurn File Added: syslog.gz
2020-02-12 05:16 MegaBurn Note Added: 0012262
2020-02-12 22:13 rhertzog Note Added: 0012265
2020-02-13 13:03 rhertzog Note Added: 0012271
2020-02-13 13:12 Danishzahid Note Added: 0012272
2020-02-13 14:56 rhertzog Note Added: 0012275
2020-02-13 15:00 rhertzog Note Added: 0012276
2020-02-13 21:36 rhertzog Note Added: 0012279
2020-02-16 15:12 rhertzog Status assigned => resolved
2020-02-16 15:12 rhertzog Resolution open => fixed
2020-02-16 15:12 rhertzog Fixed in Version => 2020.1
2020-02-16 15:12 rhertzog Note Added: 0012283